Loading

Cura won't detect my printer

Please Login to Comment

I bought the micromake d1 linear guide and just finished it. When I tried to install the default hardware from cura, it would say, "Failed to find machine for firmware update. are you sure that the printer is connected?" I tried changing the COM and baudrate but no luck. Did anyone have the same problem and if so how did you fix it?

Are you using Cura version 15.04 or one of the newer versions? I have not been able to connect to my Micromake D1 using any of the newer versions (2.x) of Cura. If Cura version is good then I suspect you have a driver issue. If that's not it, you may have a bad controller board.

It may be a driver issue, the controller board is a serial connecting device and it uses a FTDI chip to connect via usb. I suggest; first check the system device manager (I assume you are in Windows) and seek for the serial to usb OR Arduino Mega 2560
If you see any of them and a warning mark near them, correct it first. (easiest way is just download the arduino IDE and try to connect via ide). The problem (imho) is based on the issue that the vendor, WHO is not the original producer of Arduino Mega can not supply the drivers as "signed", thus, some extra secure Windows installations omits the unsigned drivers.

I can see COM 8 (disappears when I disconnect the printer) if thats what you mean by serial to usb and I there are no warning marks.

you see only com8 (in com ports) or "Arduino Mega 2560 (COM8)"

It was something like Serial C340 COM 8. Im not on my computer right now.

Ok, it seems like a driver issue, just install arduino ide and don't forget to install drivers with it
https://www.arduino.cc/en/Guide/windows

Still getting the error

For the sake of the diagnosis, do you have an opportunity to try with another pc? To see if it is a controller or driver issue

It's still not working

I'll try with a windows 7 laptop

Connect the printer via a short cable to the back of the computer usb, select the com port and the rate of 250 000

its not working either :(

try replacing the cable

replacing the cable didnt work

Yeah I was thinking of buying one but my computer is detecting it so I dont think its the cable. I'll still try a new one.

Installation cura you have installed the drivers that are supplied with cura from micromake?

I have installed cura from micromake's google drive and follow their instructions when installing it.