Loading

MP Select Mini V2 Motion Controller Firmware Update Available

Please Login to Comment

MP Select Mini V2 Motion Controller Firmware Update (not all units. read notes)

Download and Update instructions


NOTES PLEASE READ:
  • If your MPSM V2 currently has Motion Controller v34 or higher installed then you can update with this firmware.
  • If your MPSM V2 currently has Motion Controller v30 or lower, do NOT update with this firmware.
  • If you have Motion Controller versions 31, 32, or 33 please ask before updating with this firmware.

V40 CHANGELOG:
  • Added heater runaway protection. If heating and sensor reading not changing after 30 second, will stop heating and (should) halt.
  • Fix cancel procedure. - (when pressing cancel twice during pre-heat, the printhead would start moving which required the MPSM V2 to be switched off)
  • Fixed some USB compatibility issue with Linux/MacOSX system. Cura 15.##.# and Repetier-Host working on macOS. Cura 2.# and Simplify3D on macOS may not connect.

What can I do to update if I have v30?

Motion Controller version 30 is the latest version for your mainboard.

if we attempt update by mistake. What can we do about it.

More details are needed from you. Did you attempt updating the firmware and have a problem now?

Yes i tried to upgrade v40.But i was running v30.50 so i make a mistake. Printer have menu and i can play with it but y axis is wrong way when i tried to go home it goes wrong way.

If you had motion controller firmware v30 you should not have been able to use v40. The filename is different and the printer should not be able to update using that version.

If the Y-Axis is moving the wrong direction try sending "M562 Y" and then save the setting with "M500". You may have to turn the machine off then back on after sending those two commands. The commands will have to be sent using WiFi or USB.

I received my mini V2 today, it came with V35 on it.

Downloaded V40, copied the zip file contents to the base dir of the provided SD card.

inserted the card and booted the printer.

It booted normally except it didnt show the firmware version.

Now:
A: I have no access to the print screen, selecting "Print" on the printer's screen results in "!" PLEASE WAIT. this never goes away.

B: if I select monitor, all of the temperatures are shown as 0. and preheat no longer works.

C: the machine is not detected by the computer over USB by any print program, nor windows itself.

So literally NOTHING works, it turns on but that is it... less than 3 hours old and its a brick.

Fantastic.

I finally got it, I reformatted a different card and it took the update and is back alive now.

Quick side question, where can I get a profile for repetier for this printer? The info in the manual does not cover enough in terms of the profile of the printer.

Did the Update Fail?

  • Try formatting the included microSD card with

    • File system: FAT32
    • Cluster/Allocation unit size: 512 bytes
  • Try another microSD card that is 4GB or less.
  • The printer can be picky at which cards it will update from so try a few cards.

https://mpselectmini.com/firmware/motion_controller#did_the_update_fail

"Added heater runaway protection. If heating and sensor reading not changing after 30 second, will stop heating and (should) halt."

Long overdue. My first one did that at least once that I caught, ruining the hotend. The replacement I got a couple weeks ago is doing similar while sitting idle shortly after power on. Still trying to get a response from MP on that.

Did you try this update to see if this fixes the problem for you?

Going to wait to hear from MP before I do anything. Outside of the heater issue, it's unusable as it constantly crashes like this https://www.youtube.com/watch?v=JyEUngKjUIc

I'll respond on reddit

Comment has been deleted