Loading

MICRO SD CARD

Please Login to Comment

I have purchased a 32 gig micro sd card to use for my prints.
Problem: My laptop shows files that I have added to the card, but when I put it in the printer it says: No files found
Any ideas?

I have a Monoprice Maker Select from around 2014. I stopped using it in 2019 or so and then came back to it and my SD card wouldn't work. Tried to mount it, and it wouldn't take. I tried all the fixes until I saw that the metal sheath that holds the SD card to the pins was bent. I started to bend it back and it popped off. I took my machine apart and then formed it hold the SD card properly and that fixed my issue.

It's my understanding, after reading a bunch of threads on this, the issue is cards that are HC or "Hig Capacity". You need cards that just show "SD" not "SDHC" (see attached pic). I have used cards with SD on them and have had no troubles printing from them. Hope this helps! :)

If you read the mpselectmini.com website, there are a number of tips and tricks there.

Basically the card has to be an MMC spec card formatted in FAT for it to have a chance of reading the files on it.

I have the original card and I found the 2GB card recommended on the site both worked, but sneakernetting files was a pain for me.

This is why I moved to OctoPrint via a Raspberry Pi. No printing problems since then (that weren't caused by my own stupidity or design flaws in the printer itself) and I can remotely upload/slice files on the print server before printing and monitoring it remotely.

my printer does the same thing i think that the printer just cant open a drive that large and if you can i would just return the sd card and get a new one of 16 GIG

i have found that any micro sd card bigger than 8 gb will not work with the mini ,i dont know why but a small card is best

Seconding everyone else, the larger cards (2gb+) are all formatted in a file storage system with more bits. The MPSM only likes the older/smaller file format (FAT16). Without a fiddling with a separate partitioning software, I'd suggest getting a sub-1GB card, unfortunately.

I wound up having to buy some small micro-SD cards from the sort of eBay seller I'd normally never trust in order to find cards small enough to work in this and in the Mini Delta! The partition wizard approach suggested by rkolibar is a good idea I wish I'd tried instead; you can probably do this with the Disk Management tool in Windows or Apple's Disk Utility if you don't want to download something.

I have also ran into prints stalling out when using larger sd cards, which caused me to think it could be everything else but the actual issue.
https://www.thingiverse.com/groups/monoprice-select-mini-owners/forums/general/topic:34355#comment-2294857

^ had that problem too, wasn't able to get any card to print other than the one that shipped w/ the mp... tried formatting from a windows (tried each diff. block size type, 1024, 4k, 8k etc.), then formatting from gparted with 2gb and 1gb size, fat16, then fat32 in linux and mac also the Fat and Fat32 options on a mac. all no luck.
although, I had an old raspberry pi model a (the one with the s-video output) in my parts bin, threw octopi on there, and I've been up and running (almost non-stop) with solid 3d prints for the last few weeks. I would definitely recommend it as a work around!

Cards should be formatted FAT16 or FAT32.

Cards bigger than 32 GB definitely won't work (not SD or SDHC).

Cards at most 2 GB will probably work.

Cards between 2 GB and 32 GB might work, depending on the specifics of the card.

OR

  1. Get a copy of Partition Wizard (Free)
  2. Take your 16G or 32G or ...? SD card and delete the existing partition.
  3. Create a 2G partition and format it as FAT.

I've tried that. It didn't work for me. Bought a 2GB card and it worked. These printers are so stupidly sensitive to cards and file systems.

Moving to OctoPi solved so many problems for me.

This. Totally agreed! Octo-pi is the best, and also helps identify other possible issues!

Great tech info, I will try the partition wizard

I would second that, try the 2g card, but make sure it's an actual 2g card, the one I got was 4g after I zero'd it out with dd....

Card is too big. I stick with only 2gb cards on my select mini and havent had a problem since I tried a 32gb myself.