Loading

Recent Topics

Z height unpredictable on only one of two identical machines

by stickyfox

updated, see below.

I realize how ancient this printer is. :) Just hoping someone might have a clue as I've got two brand-new Mod-t's at the office. I found them in a closet and hooked them up to see if they work. Both required a firmware update so I expect they're on the same firmware, and both are (mostly, see below) working as expected.

One is great. Everything comes out almost perfect every time. I'm using Cura to slice and the terminal release of NM's software to upload gcode. The same computer is used to run both printers. I just swap the USB cable back and forth.

On one printer, however, the Z height of some parts is never correct. Parts over 1" build about 10% too tall sometimes, but the same gcode prints the same every time on the other machine.

The affected machine also tends to park the extruder so high after a print that it jams up the Z drive and must be manually lowered with the thumbwheel before it will print again.

These symptoms made me suspect an issue with the Z encoder, since the extruder moves up more than it moves down, so if encoder pulses were lost it would tend to move more than necessary sometimes, making the final Z height more than it should be. And I was really excited to find a huge fleck of dust sitting on the encoder wheel.. but removing it did not fix the problem.

Before I start probing the encoder with a scope, are there any other things I might check? Thanks!

(updated)

They are not the same firmware! I know the software prompted me on both machines that the NM store was closing and I needed to update my firmware, but I can't explain why they weren't both updated to the same version. A coworker said that there was always a problem with one printer, and suspected that was the reason for the purchase of the second one.

Poring carefully over the "printer logs" messages I discovered that there are two different versions of firmware running. The newer one (1.0.0) is the one that acts up. The older one (0.15) is the one that doesn't have any problems.

Also, while taking the printer apart to diagnose possible servo issues I found an SD card.. so perhaps I can clone the working one if installing an older firmware from the command line fails.

I also discovered that parts without z-hops seem to print normally on both machines, which makes me wonder if the z-hopping is the cause of my distortion issues. (I'm verifying that now with a test print containing a calculated number of hops.)

Does anyone know of any existing bugs affecting the z-axis in any of the firmware versions?

new_matter_mod-t troubleshooting
View Comment

Strange issue with Mod-T

by RedOrb

I am having a weird problem with a 3D printer my CAD teacher lent me, When I try to print from the Mod-T printer tool inside advanced mode, my GCODE file uploads as expected, but when I press the button to start printing, the little status bar at the bottom of the program's window says, "disconnected" then after half a second says "idle." I was able to successfully print an item before this on the printer. The issue of not being able to print also persists when I try to run the packaged test print within the program, but instead an error message appears. This is very strange, considering how I can still use the load filament function within the printer.

View Comment

z drive issues ,, and no Comm port#

by buzzerco

I am working on a friends mod-t it has a no z drive issues for the first part.

second part is it doesn't show up in windows as a comm port . The newmatter tool software sees it but other software looks for a port ## to connect to like S3D

View Comment

New Matter going out of business

by Hsus

https://newmatter.com/blog/permanent-closure/

Sadly NM is going out of business.
I've gotten a whole lot of use out of my Mod-T. Their mission statement was really cool, but the "a 3d-printer in every home"-rush seems to have died down. Will keep using it as long as I can. Historically though, I've needed a fair amount of spare parts and hot end-replacements... When that day comes I just hope I'll be able to resurrect it without their help

View Comment

MOD-T Power Supply Specs

by OCSD3D

What is the rating on the power supply? I need to find a replacement and I don't have the old one available to look at.

View Comment