Customizer Update

Please Login to Comment

Customizer now runs the new version of OpenSCAD 2015.03

Also, all the google fonts from have been added to the servers and can be used in text() :)

Comment has been deleted

Customizer still doesn't allow the import() command. If you want to be able to import() an STL file into your customizable Thing, use my script to turn STL files into a SCAD module that you can then include in the main OpenSCAD file in place of an import():

STL to OpenSCAD File Converter

Hi, how are you,can you help me with something, can you customize this for me please, it's a blade setter for my andis clipper.

Need help, I cannot export my .scad to an stl file :( Keeps saying can't open file. Any one has a solution?

Any chances for an update to OpenSCAD 2018?

doubt it, that's still in development; TV is using the latest stable release

2019 is stabile, right? How about that?

Ok, thanks for answering!

does anyone have a drone that is called a parrot copter to send me a wed address so I could use it for a school race :)

Yes. Try Google that.

Late, but a simple Google Font Test is
Works nicely - thank you @tbuser

Text with all Google Fonts ®
by Roebi
Comment has been deleted

font styles don't seem to work - and they don't show up as fields in Customizer as i guess it doesn't like the colon :

also font sizes don't seem to work (in fact text doesn't display in the scad render) nor do vectors containing strings e.g. my_vector = ["one", "two", "three"];

font styles don't seem to work - and they don't show up as fields in Customizer as i guess it doesn't like the colon :

also font sizes don't seem to work (in fact text doesn't display in the scad render) nor do vectors containing strings e.g. my_vector = ["one", "two", "three"];

I don't know if this is the place for bug reports but I' having the " Oh No! There was a problem communicating with Thingiverse. It is also possible that you are using Safari, if so click the Safari Fix button then reload this page. " using Firefox 50.0.2 on Windows 8.1

Every single customizable object gets me this error. I tried using Chrome and it works just fine ...

Dear tbuser, thank you.

The customizer menu functions correctly now!

However, i still have 2 other bugs (sorry, not mentioned before):

  • $fn=20; // [20:200]
    Results in a parameter being shown, but not changable in customizer.
    (Easy to work around):
    set_fn_value = 20 // [20:200]
    $fn = set_fn_value; //does work.

  • A=false; // [false:No, true:Yes]
    This code does NOT generate a parameter in customiser.
    Also easy to work around, but i thought i'd mention it

  • A_b=0; // [0:No, 1:Yes]
  • A = (A_b==1)?true:false; //does work

Customizable spider core (1-30 arms)

Is there an official bug report forum or location for Customizer bugs? Do you prefer Here, or at ?

My case:
With thing, the menu structure was inherited from the first file posted, and is not updated to the structure of the latest ".scad" files.

Only the items under "Global" are presented twice in the customiser, the rest is not shown.

When posting as another thing ( , part of the (new) menu appears (4 out of 8 items), and all items appear in all menus (both in Firefox and IE, tested on several windows machines).

I am quite new using to Customizer, so maybe i am doing something wrong myself, but i cannot spot a difference between the layout of my menu names and the tutorial example: .

My openscad version is 2016.07.20 (git 4bfbb94)

Customizable spider core (1-30 arms)

There's a bug with the [Global] tab. Try renaming Global to something else for now so its just in one tab.

Thank you tbuser, i was not aware of that. Will modify my thing later today!

Hey is there any way to read out the console in Customizer? liked to get some data that is dumped out by echo statement if not its now a official feature request.
/Things are about to come.

This is a common feature request that we want to do eventually. I was thinking of sending it to the web javascript console. Would you like only developers to see it or would you like the non-technical end user to see some output?

For me: id like to report values to the non-technical end user. Maybe even selectable in the customizer with a check box for javascript console or to the non-technical end user. Why not next under the part about what parameters where used.

Oh yeah, hadn't thought of putting the output on the final Thing description, thats a good idea.

Another way is to pipe echo to a .log file with the Thing that way its semi exposed to the non-technical end user.

Obviously a browser-based mini code editor inside EDIT THING would be neat but i realize this is not git hub :P Thanks for all the great work.

I'd like to suggest adding a list of fonts to Customizer so that you can say something like font="Helvetica'; // FONTLIST and have Customizer allow the user to pick from the list of all installed fonts. That way we wouldn't have to have lists of specific font names in app code (which as you add fonts will become incomplete/out of date), but instead always include the full list of fonts available.

It would be great!!

Yes, Great idea!

Yeah thats a good idea.

Is the Customizer broken? The user oraltosun told me that my quite popular Customizable Multiline Tag or Keychain does not work any more. Indeed there are no remixes for more than a day. I did not changed anything on the files.

Also the relative simple script CustomizerCube from user anjthemaker does not work any more.

Many thanks for the quick fix!

Customizable Multiline Tag or Keychain
by wstein

Sorry, the servers that generate the final STLs have been overloaded, we're fixing it.

Any progress to report on the Customizer fix? I still can't open anything in Customizer. Thanks.

Could you describe your problem a little more? Have you tried other things? Is the problem in opening things in Customizer previewing or in generating the final stl? I think you might be having a different problem then what was referenced in this thread.

There seems to be a missing library...

I get this error message on the spiral horns thing and the customizer cube test (as well as my own things).

/usr/local/bin/openscad/openscad: error while loading shared libraries: cannot open shared object file: No such file or directory


Any ideas on what might help here? Problem exists in both Firefox and IE8, although they both give different error messages. I've tried a number of different customizable objects and the result is the same for all of them.

Thanks. I get one of two problems when I try to use customizer. Either my browser gets stuck in a loop on the login screen before I get a chance to enter my info, or if I manage to log in, I get the following message:

The page isn't redirecting properly

Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

This problem can sometimes be caused by disabling or refusing to accept cookies.

Do you perhaps have 3rd party cookies set to blocked? Are you using an adblocker plugins?

Thanks, but no to both of those. I did manage to get it to connect successfully about every 5th time if I just kept trying to open the same object in Customizer repeatedly. I don't get it.

I just tried this very simple thing and it works ok, so the problem doesn't seem to be system wide.

Twisted Spiral Horn Generator

Is it possible to install the complete Google Noto fonts?

I would like to see some CJK glyphs. But also many rare scripts would be available, see the complete list here:

Many thanks for your great work!!!

Thats a great idea. I'll add the noto fonts to our TODO list.

Could you please add also an Emoji font like "Google Android Emoji"?

This would bring hundreds of cool ideograms and smileys:

The Customizer is very usefull. But multiple file support. Using own libraries, without coping all the implementation in one file would make life a bit easier. Are there any chances to implement that in any way? Or does it already work and is not documented?

Yes, please add this. I have an extensive library of OpenSCAD routines and packaging into one file prevents me from wanting to upload designs.

Sweet, i updated my
Sweeping name plate [], Round Text Sculpture [] and Customizable 3D name plate []
to use the new customizer text functions. Also the offset function works now... All looks cool and round, like it should be.

Thanks for the font list, wstein!

Sweeping name plate
by makkuro
Round Text Sculpture
by makkuro
Customizable 3D name plate
by makkuro

If you increase the convexity on some of those linear extrudes it should display correctly in customizer.

I increased it to
rotate_extrude(convexity = 64, $fn = 64)
for and it does not improve the display in the customizer...

Sweeping name plate
by makkuro

Hm, try setting it on the linear_extrude calls too.

@tbuser I think this is a general problem on your server installation. I think things using 3D intersection and 3D difference are affected. Did you already try to activate the goldfeather option? This may be a cgal or driver issue, so this may help. This is only a guess. I have tried it under Fedora 22, Windows 8.1 and Debian 7.8 but I did not run into that issue.

Yeah we are using goldfeather (things are much worse without it) I believe it may be a driver issue as it's using an X virtual frame buffer because the server has no video card.

Hm i did it, still doesnt show up perfectly...
Maybe its too complicated for the viewer.

I have made my first thing using Google font. and it is impressiv having so much fonts. Now I am waiting for the next generation of Customizer, is there any development going on?

Customizable Multiline Tag or Keychain
by wstein

Great! Easter Egg Maker 2015 now works with Customizer.

Thats not only good news. The new OpenSCAD version also may causes issues on existing customizable things. There is now a vertical gap in the heart - this seems to be a bug of latest OpenSCAD. So you should check all your customizable things. HF!

It would have been more clever to make a CustomizerV2, maybe.

Anna Heart
by amsbr

Sorry about that, there's some obscure bugs that are only affecting some scripts. I reported this one to the openscad devs.

Today is the greatest day. Woooooah there are a lot of Google Fonts.