Loading

Please help wont connect

Please Login to Comment

Usb will not connect Please help
ok ive been running my Tronxy for bout 5months no issuses then my laptop started being wierd so i did a basic reset. after no matter what i tried, read about nothing sems to work. baud rate same both printer and com port. com port shows its as ramps and does so as i plug and plug back in. printer shows the correct com and as said baud rate same but will not connect. tried uninstalling drivers, looked for updates. even took another pc hooked it all up and still can not connect. im sorry if this not the place to ask but still have hopes someone can help as me and kid love printing stuff everyday so please and thanks for any info that might help us out

I've found a post doing a quick Google search, here's the text.

Here's a tidbit that might be helpful to people.

3D Printer: Tronxy X1
OS: Windows 10 (PC)
SW: Repetier-Host v2.0.5
The TronXY X1 boots at 115200 baud (you can change it in Configuration, but each power on it will reset to 115200). In Repetier Printer Settings I set the baud rate to match at 115200. My PC automatically recognized the USB device as USB-SERIAL CH340(COM5).

But...

I had to go into my PC's Devices and Printers, right-click the USB-SERIAL icon, go into Properties->Hardware->Port Settings: change Bits per Second from 9600 to 115200.

All good now.

Thank you for ur search, i did go to my device manager, opened ports under ports it says ramps(com) i did chang the busd rate from 9600 to 115200 the same as repetier baud rate. I did read that the ftid drivers was the driver to use, and i did try both that came on sd card. I will try the ch340 driver again to see if connects. I truly Appreciate the help as nothing ive tried works.

ok tried the ch340 driver again, in repetier host it it says signal not detected , forced start. said connected but nothing came up. no extruder/bed temp, can not move with controls. i tried updating driver once it took me back to ramps second time it updated ch340 driver but still said no signal force start and no controls. i am sorry for having to bother anyone on this i am at a loss of what i could have done wrong

Have you tried a different usb cable?

i just tried brand new usb cable with same results. dang i totally got something messed up just not sure how or what and i do thank you Phistterhut_inc for ur time

Ok i tried 2 more cables, still same. Repetier says when connected no start signal forcing start. As it is connecting the red light on printer board is lighting up as it connects. Repetier shows connected even to point it shows extruder/bed but does not show temps. Also shows in control that its connected allows me to turn on extruder/bed even what i have them set to but wont heat up or move with repetier. I did use the control panel that comes with the tronxy and it heats up and i can move and home it out. Is it possible the usb port on the printer is bad. Im not the best at computers but it does seem to me that it is Recognizing the printer both pc and program as if i unplug printer while connected it looses connection when unpluged. This will be last as i dont want to keep buggin anyone

Have you reset the printer and computer then tried again? You're not bugging anyone, it's just that taking a few minutes to wander through Google is likely to find you an answer first. Chances are someone somewhere had the same question.

Another search for the tronxy baud rate led me to this post

If it's an issue of EMI, you can print a case for the board and use metalized duct tape to line the outside and connect the tape coating to earth ground. If the cable is the issue, you'd have to go with a higher quality one that contains a metalized foil inside connected to earth ground. Your PSU and computer should both be plugged into grounded outlets. They sell testers for that kind of thing. Reading that post makes me think it's EMI, especially since it says connected but you don't get proper communication.

i promise you ive done the same google searches, i have read many post most of which never tell u the final solution, i have tried resetting, deleteing, reintalling, both drivers and software,read the post on baud rate which is why ive been making sure all is the same. i tried 4 cables 2 of them come from my solidoole3 and 4 machines plus a brand new 1. tried a laptop and a tower both of them doing same thing.

ok i finally got repetier connected and moving /heating printer. what i did was go to github downloaded there ch340 driver. i still cant connect to mattercontrol but thats ok im just happy to be connected i very much thank you Phistterbut_inc Thank you for helpin, thank you for your time

Oh good, you found a solution. Link the github for anyone with the same troubles would you? Don't thank me, you did the thing :)

Fantastic. You know I should have suspected the drivers because FTDI has released patches to brick fake FTDI chips in the past.

Yes sorry windows 10, printer is tronxy p802e with no issues up till now will not connect on tower or laptop. I can move it with tronxy display controller. Ive tried mattercontrol, and repiter host to connect. Ive tried both drivers that come on the sd card from tronxy. Thank you