Loading

Bl touch working correctly?

Please Login to Comment

Is my BLT touch working properly? I'm not sure I've started a few Prints but I don't see any correction in the Z , but I'm thinking it may just be to subtle for me to see. Too test this ran the bed leveling sequence and moved it to the back right corner which I intentionally left a little bit lower and then had the printer move to that corner and lower to zero. It did not seem to account for the offset. Is this normal in Marlin for move axis command

I use this code at the start of every print, works perfect!

G21 ;metric values
G90 ;absolute positioning
M82 ;set extruder to absolute mode
M107 ;start with the fan off
G28 X0 Y0 ;move X/Y to min endstops
G28 Z0 ;move Z to min endstops
G29;
G1 Z15.0 F{travel_speed} ;move the platform down 15mm
G92 E0 ;zero the extruded length
G1 F200 E3 ;extrude 3mm of feed stock
G92 E0 ;zero the extruded length again
G1 F{travel_speed}
;Put printing message on LCD screen
M117 Printing...

To set your Z offset use

M851 Z-0.5 adjust till you get it right at the center, Thenn M500, M501 & M503 to save and check its in the Epprom.

Thanks. My starting G-Code is almost identical. And I have adjusted using those commands. But for some reason I do not get a good mesh. The bed doesn't seem to be all that uneven as I can print without Auto bed leveling. Maybe I have a bad Marlin file.

Couple of things
Assuming you bed level before each print . Make sure the bed level command is the last thing before printing ! If for example you use a G28 ( home all axis) its resets the bed level data.
SO your start gcode should be something like
M107 : make sure the part cooling fan is off
G28 : home all axis
G29 : perform mesh bed leveling

You also need to research and understand Z offset. Its the amount below Z zero that's used when printing This is what you adjust to set your first layer height/ bed adhesion

so put g29 command in in to my slicer settings but still no luck. now it seams that the nozzle is off by about 1mm form bed. and I have used the steps in the this video https://www.youtube.com/watch?v=y_1Kg45APko to calibrate the z offset in the center of the bed. if I print with no bed leveling it I get a ok first layer but with the bed leveling done I get approx. 1mm off the bed when I am trying for .3 off the bed.

any ideas?

ill take a look at the video but first need some info from you.
What machine do you have ?
what controller does it have ?
do you print with a PC laptop connected or SD card ?
does it have an LCD control panel ???

Omg that's my problem I had no idea that homing reset the bed leveling. For some reason I thought once you bad level and safety eeprom the mesh would be saved.

Since the bed leveling sequence isn't part of the actual g-code you are getting ready to print, I'm not sure your test is valid. Did you try one of the bed level prints? That would be a good way to check. Here's one, there are plenty more. https://www.thingiverse.com/thing:2187071

Bed Level Test

Thanks did not know I could do this