Loading

Extruder is not feeding

Please Login to Comment

Hello everyone! I'm brand new to the trade, I bought one of those Chinese knock off's of the prusa i3 3d printer. Similar to a geeetech but not as nice. I managed to assemble the entire device and got everything working despite the lack of any instructions. However the final issue I've run into is the extruder. Its not feeding and the only way I can get material out the other end is by forcing it through. The extruder came pre-built, it's making a small clicking noise and when I place my hand on the filament to help feed, I can feel it almost pushing back each time it clicks. I'm able to assign the printer to print a job and in the very beginning right before printing, it grabs ahold of the filament and actually backs it out of the extruder for just a half inch or so, this is the only time it appears to grab the filament correctly. I have the wires plugged in correctly but I'm wondering if the manufacturer put the connection together backwards or if 200 degrees isn't enough. Or if maybe there is a tensioning screw..(it was late at night when I worked on it last). Maybe I plugged it when i was forcing filament in, I don't know.. I'm requesting your support and appreciate you unsung heroes and your valiant efforts to keep me sane!!!

P.s- this is the printer http://www.ebay.com/itm/351598468255

hey so my extruder motor isnt moving at all it is not making the effort to pull the filament i any thoughts?

The temperature for PLA was 180 deg. first at my printer. Thiis work not good. I heard a clicking sound every few seconds also the distance between plate and tube was araund a peace of paper density. I increased to 215 deg and the clicking dissapeared.
Then the printing become good for some time. I have a temp range between 205 to 222 selected. For some time this range works fine while printing.
When the Mosfet heats up and the cooling plate there has a Temp of about 70 deg the Temp control start to extend. The heating stops than after some minutes by 270 deg and it restarts at about 100 deg or so on. If I would not intervent my nozzle would burn away. It must be ensured that the extruder temp is regulated proper. You see this at the LED of the controller. When the Mosfet heats up the mikroproz seems not to be able to proper control the Mosfet again over the PWM port directly. The actual work aeound was to install a fan at the head of the controller because the position and the origional fan is not proper here.

I also have a ctc prusa i3.
When I assemble it I face first two problems:
The extruder stepper driver didn't work and the extruder heater was allways on. I installed a new Mosfet because the original was bad and I replaced the stepper module for the extruder. Then the printer works and I could made 3D parts. When I produce a larger part I recognize that the temperature regulation become more and more extendet. The reason was again the Mosfet. It become hot also the Mosfet has a current capability of 55A. When I cool it with temperature spray the regulation was at once proper. I install a fan cooling directly the Geeetech 2650 board over the 3 mosfet and all was okay then. The reason for that problems are the pwm routine for the temp regulation. Next I will change that part of the software.I have found the source for the aduino Ide for that board and printer.

PWM is good and does not make problems itself, but I think you have picked the wrong FET, not every Fet in that class will work fine with 5v signal, if you picked one that needs 10v it will run hot for sure.

Btw. the stepper didn't feed when I've got my CTC Prusa i3 pro B with GT2650, but it was only a too low setting of Vref on the printer driver board, after rising Vref it feeded well.

The stepper is working either now. The problem was a defect smd poti on the module.The Mosfet instead is the 5V type.

You have to know, that the original transistor was bad when I receiced the board -also I have nothing done with it.When I desolder it I see on the board signs for overheating. So I think that that board was bad from the beginning and was not brand new.
Iordered a package of 10 Mosfet - Type exactly from the gt2650 schematic - definite 5V type, To220. I connect it with thermocoupling material. The temperature control works than for 15 min. or so and than begin to extend temp. range. When I
cool the Mosfet it falls back in proper temp control within seconds.After installing a small fan it works now proper and the 3d printing is also very good.
Before the following happens:
The temp become first to high and than to low. When the temp decreases 160 deg the extruder stops and the printing continues also extruding is interrupted. Some seconds later heating starts again and now extends shortly 240 deg. The quality there become at the end of the printing therefore poor.
I was of course estonished when I recognized that effect.
Recognizing the circuit the PWM pin of the micro proc directly connects to the gate of the Mosfet.
It might be that a different Mosfet work better but this one is definite the appropriate 5V type. But the total current of 50A requires about 8V Vgs. We need 5A about for the extruder which can be controlled with a Vgs less than 5V.
Cooling works for first - I have also ordered a new gt2650 because I construct a own printer 800 x 800 x 700 as a new project and have designed a electronic extender for that.

So I will flash the prusa firmware and try out also this one.This fault is a problematic one because the extruder becomes very hot. The fillament changed color and begin to smoke when I faced that for the first time.

When I have got further details I will post them immediatelly.

Ok, seems that there is another fault.
However the controller can drive two hotends, so there is a second and maybe working channel.
I think you has to activate the second extruder/HE inside FW and when activated you only have to set your slicer on the second extruder/HE.

PWM is running well on almost any 3dprinter that does not work with relais and the control and temp curve is much better with PWM than without. Just try the second extruder/HE channel, if it works your are fine, if not open your window and throw that controller out.

Hello
The printer actually works because I take the gt2650 housing with integrated fan from Thingiverse and added it to the printer case. But I have annother improvement in schedule which I wants to try out. If you look at the datasheet of the used Mosfet Stp55nf06 you see that this part is here suboptimal.
For other projects in the past I use a Sup70090e Mosfet if Vishay which has a much better Ugs diagram for direct use with 5V direct driven PWM. Here it handles not only 12 - 15A like the Stp but 50A instead. Also the switching losses will be much less. This type costs about 2.80 € per peace while the Stp costs only 0.80 €. Both types have a To220 case.
By replacing this Mosfet against the other the problem will be solved for sure.I will give you feedback when the problem is solved so. This effect was posted over here because some of this China Makers are burned away and this incident might be one reason for that.

Hello
I am brand new to this. I have an athena model and am probably not going to use the correct terminology. I am trying to feed new pla into the extruder and the motor that feeds the pla is making a horrible humming sound and will not feed the filament thru.

I have a similar (but not the same) printer. What I found was my stepper motor was bad. If you have another motor, swap the connection to the 'spare' and see if it works, If it does, the motor is bad. If not, then check that all the connections are correct. Otherwise, check the stepper drivers.

Hello Galasroman,

I too am new here (this is my first post) and I too bought that exact same unit recently and I too had the exact same problem.

The solution I found is the voltage being piped to the extruder motor. Take a look a the four drivers on the arduino board (they are the little red PCBs) locate the one driving your extruder - there is a tiny silver disc that controls the voltage. it can be turned ever so slightly to increase/decrease the voltage.

you need to use something non-conducting (like the rubber tip from a pencil or a ceramic screwdriver) to very delicately twist that disc (imagine twisting the hands of a clock in 5 minute intervals); i did it whilst the printer was running and clicking. when I hit the sweet spot the extruder started pulling through the filament nice and smooth (and at much lower temps than i had been using before)

The proper way of adjusting it is to disconnect the motors and adjust the voltage from reference point beside the pod to ground using multimeter. On my particular i3 I try to make sure that x, Y, and E are at 0.5 and z is at 0.7v. For CoreXY I used the same on all axis cor my particular setup.

yup tune the motor

ATTENTION!
You can easily kill your motordriver that way!

If you really wanna optimize the driver setting, swap the driver with the extrudermotor to another channel like the X channel for example. All other channels than extruder have a holding current, that means that you can hear the point you are by listening to the noise after you let the motor travel a bit. noises will be "whistle" - "none" - "some kind of plopping". "No noise" between "lightly whistle" and "plopping" is optimum with best but save power.
And remove the filament from the feeder before doing that.

Normally 200º for Pla is a good temperature,
The first thing to do with a new printer is to try to push the filament manually as soon as the hot-end is hot and it should go down very easy from the nozzle, so you are sure that the temperature is at least good to start before blaim the poor extruder :-)
Then you can start with the bed temperature, i personally don't go up too much, 50º for me it always works fine with the pla or Pet-G (i do not use Abs).
Good luck with your new printer

I have the same printer, and had the same issues. It took a while to get it sorted. The extruder was not getting hot enough, checking with a laboratory contact thermometer read only 170. I raised the temperature, and after much fiddling with settings managed some rather poor prints. I then started on mods. First I checked the nozzle size using a vernier gauge on freely extruded filament - with support, it was less than .3mm, when it was meant to be 0.4, I changed the settings on the printer to 0.3mm and this improved things. As a result I bought a couple of 0.4mm, this much improved things. The extruder had obviously had problems with pushing filament that was too cold through a hole that was too small. I changed the extruder to an E3D with a Bowden feed, I printed the mount myself. Totally different machine. OK I've had one or two other problems but they've now been sorted thanks to advice from here. Using that setup I proceeded to print various other mods. Now I'm pretty happy.

im new to printing but have a lot of tech experience. first and foremost i print pla at a minimum of 210 (not saying you have to its just what i do) most of the other filaments require higher print temps so it is most likely that your nozzle temp is too low. however if yoou are using pla and are indeed printing at 200 it should still print. in that case it is most likely a mechanical or software issue. the way i would go about trouble shooting this it 1st. unscrew the nozzle from the hot end and use the lcd screen to manually advance the extruder in the positive direction. see if the filament advances out of the hot end properly. if it does not feed properly try to advance it in the negative direction. if it feeds properly in the negative direction then either the connection is reversed or it is reversed in the firmware or a external setting. you may need to do a firmware update, or search how to invert a stepper direction (i am not sure how to do that). if it feeds properly in the positive direction then it is functioning properly as far as direction goes. next advance it in the positive direction and try to hold the filament back above the extruder. if it is still feeding through moderate resistance then the extruder is functioning properly. if it doesn't feed even with light resistance then there may be an issue in the extruder. take a look to make sure that the gear is not loose on the stepper motor for the extruder if it is loose tighten it and repeat the last step. if it is tight make sure the spring for the tensioner hasn't become dislodged and that the screw is set correctly. if this is all functioning properly and it is feeding correctly then it is most likely a temp problem or a clogged nozzle. if your printer is in a room that is very hot or cold it can affect the temperature of the nozzle also if it is a very windy or drafty area it can affect the print. you can try to raise the hot end temp if your printing pla to about 230c and using the ldc menu advance the extruder if the material flows out easily then it was most likely a low temp clog. if it is coming out really thin or not at all then it is a clog or burr in the nozzle and you need to do a thorough clean out and if you have a pin or drill bit that can fit run it up the nozzle to make sure it doesn't have a burr in it. if the nozzle is clear and you are still having issue and printing with pla i would start at 110c and do test prints increasing the temp by 5c every print until you get a good result. it may be that your thermistor is not reading correctly. my kit came with a faulty one and when i replaced it i did not push the replacement in far enough so it was off by almost 10c. this should point you to an exact problem and offer some help i hope. can you tell us about the filament your using. pla abs petg nylon flexfil ninjaflex wood ect also most filaments have manufacturer recommended setting on the spool if you could provide those as well.

OMG you guys are amazing, I didn't realize that my nozzle is extremely fine. So I upped the temp to 240 and also noticed my bed was a bit too high so I lowered it. I also decreased the feed from 100 to 60 which got rid of the clicking! Lowered the overall speed too... It's printing it's first job now!!!!!!!!!!!

Thank you all doooo much!!

Sounds that your extruder temprature is to low and your filament isn't enough on the liquid side to be pushed through the nozzle by the feeder. When you push it through by hand the temp will drop a little, what's enough to block completely.
Raise the temp and you will be fine.
All filaments have a temprature range like 190°C to 220°C, the smaller the nozzle the higher the temp must be cause it have to be more liquid to go to that small hole. A good starting point would be for the range above and the standard 0.4mm nozzle the middle of the range(205°C) + 5°C. But don't think it's a fixed number, any filament, color, nozzle and speed needs other temps and noone knows how exact the temprature reading of your printer is.
Too cold ends with inconsistance flow and no flat layers, too hot normaly ends with spiderweb from traveling and bad bridging.

EDIT:
Followed your link and hey it's the small CTC Prusa i3 Pro B I have too.
The cheap plastics feeder will work a while with low temps like for PLA only, but it'll wear out very fast and has no screw or spring so you should order a better one next time.
I swapped from the plastics to one of these:
http://d3d71ba2asa5oz.cloudfront.net/12022912/images/bi089_286__1.jpg
You only have to open the small hole a bit and use a two shims between feeder and the bracket below.
Another problem I had with that printer was that the bed was much colder than shown in display (10°C to 25°C difference) with it's unusual 50k thermistor. Now I have an IR thermometer to read the real temp to correct them, before I had a lot of warping with any filament. If you want you can fix it with another firmware like Marlin and another thermistor (100k). Marlin should also be the way to activate the added PWM fan out.
If you wanna have the pinout of your board, search for GT2560 (Getech), the board itself is of good quality.

I also saw an issue where the gear had slipped off the motor, resulting in it not being able to grip the filament properly - I only discovered that when I stripped the extruder down to try and unclog it - once I re-attached the gear properly, the issue went away

Does the filament come out of the extruder head trait down or does it spiral? if it spiral its clogged a little but, that should not effect the extruding to much. what size filament? also have you plugged all the right configs into the print settings. Is the filament loose or tight when you hear the clicking?

I have a very similar model, and a similar issue - it appears to be caused when the extruder head is too close to the print bed, when levelling the bed, make sure a sheet of paper pulls out between the extruder and the bed without much resistance (there should be a slight amount, otherwise the filament will not stick to the bed

If you can feed it manually and it is not stuck or clogged, I would check to make sure the extruder feed spring is putting enough force for the gear to get a grip to the filament.
To test it pull up the handle manually to see if it starts feeding and stops skipping.

I can feed it manually to a point in which it stops, and if I force it aggressively a fine spiderweb like amount of material comes out kind of. So I guess it is technically blocked

Make sure the temperature sensor (what ever came with it) is actually seated and is making contact inside the little hole on the aluminium block. I stuffed some aluminium foil inside to keep it in there and prevent it from falling off.

If the temperature is too high, or too low you will have a clog. too high temperature will cause the filament to burn (then you have to take it all apart and try to clean it if you can), too low will cause it to be solid and won't flow.

if its spider web thin and not as thick as a .4mm pencil lead its clogged and needs cleaning or it was not fully cleaned of debris when drilled out in manufacturing. Clean that out, disassemble it all per guides for the type it is a clone of. It is almost certainly a clone of a well known model with some guides online. Google images to identify it.

What filament are you using? If PLA, 200 is fine, but ABS is 230 min (i think). The skipping is definitely the extruder trying to push down your filament and something is not letting it go through, could be a block or your filament being too cold and still solid.

Hi, I also had this problem with my Prusa i3 pro, and tried almost everything to check if the extruder was damaged. I tried to feed manually but it got stuck, it made no difference how much I increase the temperatura, the filament didn't get out. I knew that the hot end wasn't colgged as I disassembled it and the motor was okay too, but for any reason when assembled it again it didn't work and a continuous click sound all the time.

You know what I did to solve it? I called a guy expert in this kind of machines, and he simply changed the filament. Sometimes, a cheap filament is a loss of time and money. He also explained to me how to remove the filament when you finish your printing: with the extruder still hot, feed manually some filament inside and see how it gets out, then stop pushing and pull it out. After this remove the filament hanging in the hot end.

For me PLA Works fine at 210ºC. It depends on the printer.