Loading

Firmware Versions

Please Login to Comment

I'm curious what everyone's X-Max is running firmware wise. Qidi tech support told me I was on the latest, but my machine was built early 2019.

Version information can be accessed from the System->About menu.

Mine is currently

Version:v4.2.6.5 /W0.0.0
UI: Blue+ 1.0

EDIT: 20-01-07

  • Added firmware package as received from Qidi support. I would recommend saving your current configuration with the M8512 command first instead of running their stock, just to make sure your settings don't change.

Instructions from Qidi:
Please put these files on the USB drive home page, do not put them in the folder.
Power off the printer,then insert the USB drive,reopen the printer.
1.print the "update.qd"file. It will restart the screen and makes " dididi" sound.
2.print the "UI_4_3-Single.bin" file
3.print the "wifiUpdate_full_V10.0.12.bin" file
4.print the "PLUS X-MAX Config.gcode” file

I am just a little confused with versions here. I have had my X-Max for a month or so and, in communicating with Linda on another issue made an enquiry about software updates. She sent me Ver 2.27 which updated perfectly. Are we running a different board now? What's with ver 4.2 or 4.3 etc?
Also, it seems a shame that firmware updates aren't available for download from QIDI.
Perhaps we just need to make the latest version available through this site. I'm not sure how to do this.

Qidi can provide firmwares 2.27 and 2.29

I tried 2.27 in order to use a filament sensor, but the filament extend button, retracts instead.

I will test 2.29 to see if that solves the extend button issue. OK, I loaded 2.29 Extend button works properly now

Hello!
Sorry if it's not clear - I use an online translator. Yes, I acted rashly.
I have such a problem:
I tried to update the firmware according to this instruction.
After turning on the printer with the inserted USB flash drive, on which the firmware is installed, several signals were heard.
The display lights up and there is nothing on it, the fans are working, the backlight is working, nothing else is happening.
The printer was manually turned off and on several times with and without a USB drive.

Please someone help to restore the firmware. The native version is probably 4... (I don't remember). Now, when I insert the flash drive, I see that attempts are being made to read from it - the indicator is flashing. And no more ...

I wrote to technical support twice, more than one week has passed - they are silent.

maybe someone has old firmware versions?

tech support finally answered me. they offered to check the connection of the screen loop. and as a result, they promised to send a motherboard, a cable and a screen.
such a thing ...

the components have arrived. replaced the motherboard. firmware version 4.2.14.4

Mine was delivered May 17, 2019
System: QIDI Tech
ID: a whole bunch of numbers
Version: V4.2.6.5 /W10.0.12
UI : Blue+ 1.0

V4.2.6.5 /W0.0.0
Blue+ 1.0

Bought around black friday of 2019

Mine is currently

Version:v4.2.6.5 /W0.0.0
UI: Blue+ 1.0

I've had mine for about a year.
V4.2.6.5/W10.0.12
UI Blue + 1.0

I've long suspected that Qidi does not update the firmware because either they haven't implemented a method on the board for remote flashing, or they don't want to so easily expose their code to reverse engineering. I, for one, would love a flash utility so that I could flash it with a more mainstream Marlin. I love my printer, but the only innovation I see in it is the model display on the LCD while printing - and you only get that if you are using their captive slicer. Neat, but a waste of both bandwidth and memory. Otherwise, their implementation of Marlin is somewhat handicapped with many standard Marlin commands that do not work as they should - if at all - on the beast...

The boards (and I suspect firmware) are made by a company called Chitu 3D, so Qidi would have to request firmware changes for them to be implemented.
The boards do have a bootloader that looks for a firmware file on the usb drive. If they ever send you an image for firmware update all you would have to do is load it on the flash drive and turn on the machine. Those files are usually compiled, so most casual programmers would have a hard time reverse engineering anything.
To get marlin on there all you would need to do is pin map the entire board. Not impossible, but quite a process.

As posted in another topic, someone has made a Cura plugin that inserts the model preview as well as correct time amounts.

It would be nice to have some open source firmware, but then again that is not the type of printer it was designed to be.

Mine is:

Version: 4.2.6.5 / W 10.0.12
UI: Blue+ 1.0

Version: 4.2.9 / W 10.0.12
UI: Blue+ 1.0

Ok, looks like you are the first to report a newer mainboard version.

Mines is exactly same as voksbug. I have W10.0.12 too

Well that's interesting. There has clearly been some changes without the number changing. Mine does not have the "System: QIDI TECH" listed at all.
Also I think my wifi module is dead.

Same. The only difference is I have: /w10.0.12. You likely have the same because mine sometimes shows "W.0.0.0". Back out of the "About" screen then open it back up. When I do that, it changes to the info I typed above.

Mine's the same as yours Funkton except I have W10.0.12 I purchased mine about 2 months ago
Has anybody asked them why they don't have firmware blobs on their website?