Anyone got WiFi working


Please Login to Comment

Hi everyone. I just got the x-plus and have it all set up with the exception of WiFi. Every time I try to connect it to my wifi I get a failure. I got in touch with Qidi support and they gave me some gcode to run. Still doesn't connect though.

The gcode if it helps anyone else is:

My firmware version is V4.2.6.5 /W.0.0.0 with the UI Blue+ 1.0.

Does anyone know of any other way to get the WiFi connected?

I also made my ip for the qidi a static ip and it connects every time now. It took me about a month to figure this out. Maybe it will help you.

Generally got it working now (qidi print doesn't always connect, but the control panel does). I've currently got mine picking up a reserved dhcp address, but will see if a static IP makes it more reliable.

I am having the same problem. Cannot connect to Wifi no matter what I do.

I got there in the end. I replaced my router (I'm on VirginMedia and was having lots of wifi disconnect issues with their SuperHub anyway). I bought a netgear nighthawk wifi router and the printer connected to that first time.

I still have problems with the qidi print software not finding the printer, but can work around that using the qidi control panel (install from the control panel menu in qidi print). First time the control panel started up, it defaulted to Chinese text - close it and open it again and it should have picked up your language settings. The control panel connects every time and you can transfer gcode over WiFi from it.

If you e-mail the support, they do try their best, but language would appear to be a barrier. They also offered me free spare nozzles & tubes if I gave them a review on Amazon - haven't done it yet, but I would be giving it a positive review anyway, so might as well get the freebies! :)

Thanks for that info!

Unfortunately, I can't get the control panel to work either. I can detect the printer on the network now, but it still won't print. And I cannot get the English text to show up, so I am sort of blind.

Also should add that you need to keep a USB drive in the printer for it to accept any files.

My control panel just switched to English after closing it down the first time.

This isn't a huge help, but a screenshot of mine with the English attached. Highlighted bits of interest. Green bits - refresh list of printers. Once found, select your printer and press the link button (assuming it doesn't automatically link - check the status of the printer)

Purple area - drag your gcode in here to copy it across. To start a print, select it in the list of files and press the button highlighted in cyan.

Hopefully, this gives you enough to check you can copy files to the printer and fingers crossed yours switches language soon.

Huge help Darth.... much appreciated. I don't know why I cannot get English text to show up, but I will be sure to get in touch with them.