Loading

Need Help With No Audio From 3.5mm Jack

Please Login to Comment

I have asked this question over on the Raspberry Pi forums as well as the Raspberry Pi reddit, with no one offering me any help whatsoever. Thought I'd give this group a shot...

I have a Kano computer kit utilizing a Raspberry Pi 3b. I put Raspbian Buster on an SD card and setup everything up. No matter what I do, I cannot get audio output on the 3.5mm jack with one exception. I have tried forcing Analog Audio using raspi-config , right-clicking on the volume control and through amixer. Audio out through the HDMI interface works fine. I can get audio output through the 3.5mm jack if I force omxplayer using "-o local" but no other program will use the audio jack including VLC or system sounds and the volume control has no effect when I run it that way - even if I right-click and switch to HDMI and back. I have read that PulseAudio might be an issue, and I did try to uninstall that with no difference, but I need that installed anyway for the program I need to run - SilverJuke. I have also noticed that when I run raspi-config, the audio setting doesn't seem to be sticking - i.e. it always defaults to the default setting each time I enter that menu, whereas the other settings seem to stay where I put them. I am out of ideas if anyone could offer some advice/help....

try plugging the aux into the monitor headphone jack, if applicable

I finally wiped the SD card and started fresh. It worked, so.... Thank you for the reply, though.

I personally can offer zero assistance whatsoever, except in offering another potential source of info / assistance - have you tried element14.com?

https://www.element14.com/community/welcome

Regards

I appreciate that. Since I wasn't getting any help from the usual sources, I decided to load another SD card with a fresh install of Raspbian and see what broke it, testing each step as I went along. So, I ran raspi-config and forced audio jack output. Good. Rebooted and installed pulseaudio. Still good. Rebooted and installed gstreamer. Still good. Installed Silverjuke. Still good... So I have no idea what broke the initial install except maybe that I did things in a different order? I think I installed silverjuke, then gstreamer, then pulseaudio and finally tried to force audio output? But why the order would matter.. I don't know. All I know is it's working now... but thank you again for that link. I will keep it in case I ever need any help with another problem :)

You're not resetting the pi by pulling the power without shutting it down are you?

Naw... this thing has got a physical on/off switch but I always go through either the GUI shutdown/reboot menu or issue a 'shutdown -[r|h] now' command.

Why not script your button with the GPIO library?

If memory serves, this group requires a minimum length of text to avoid spam bots flagging my links suddenly and violently.
Here we GO!
lksjfsjlkfjsdlfj lsjflk jslkfj lksjdf ljslkfj lksj flksjl fjslkjf lksj flkjs lfk jsj lksj kljs lkjslk jfl kj lkjs kljsl kjlk sf ljsdkj lj f
that should do.

lol... Yeah, I've seen that and I've threatened to do just that on a Libre SBC that I'm running as a file server, but in this case, it's a GUI jukebox, so just powering down that way is no big deal. If it were a headless system though, yeah... definitely a power switch. I don't know why that isn't standard on the Pis out of the box...