by 3D-ME

RepRap is humanity's first general-purpose self-replicating manufacturing machine. It is an open-source project that focuses on the creation and development of 3D printers that can print (some of) their own parts.

More information can be found at the wiki: http://reprap.org/wiki/Main_Page

This group is a place to discuss and share files related to, but not limited to; printer designs, modifications/upgrades, calibration, etc.

Join to share your own RepRap related designs with this group!

View Comment

New heater Cartridge problem.

by Hesus

Hi. My thermistor was showing wrong temperature about 20-25 degree less compared to the new one. They are basic glass 100k thermistors in J-head v5 clone with standard 40W 12V 4ohm ceramic heater Cartridge. I thought that would be great to change the heating Cartridge too bcs i used it maybe 500-700 hours :v. Swapped both of them and now extruder can't even reach 220C.. The old one heated perfectly to 230C while printer was self leveling. The new one is heating about 5 minutes to unstable 200C... I did PID tuning in pronterface the first one with 230C and 10 Cycles ended up with timeout error. The second one with 180C and 8 Cycles ended with 5 Times higher PID values compared to the old heater. On new PID settings and after restart printer still can't reach 230C. Running on the newest marlin and arduino. Its my own custom 3d printer. Fan is blowing on fins exactly one fin above Heat Block. Never needed any silicon sock or other stuff. Cartridge and thermistor is secured with screw and Red titanium high temperature silicone. Cables are tight and undamaged. Any ideas?

View Comment

Pi wont connect to MKS Gen L Board

by SaltyTaco

I am plugging the pi in to the type B USB port and i keep getting the following error:

Error: Failed to autodetect serial port, please set it manually.

The pi is fine, it worked onthe previous melzi board, but now it wont connect to the MKS board. Is there some setting I am missing here? Any help appreciated.

View Comment

Lulzbot AO 101 and Simplify3d

by Leftyhokum

Just wanted to throw a thread here that made it apparent using the Simplifi3d - LulzbotTaz 3 settings for older model Lulzbot printers works well. The only things I had to do was set the platform dimension to the smaller size of the AO 101 and add a script to make sure the fan is running. I had been messing with these settings for awhile and finally broke down and bought Simplify3d. Man am glad I did because even though this is an old ass machine it works like a dream.

View Comment

Printer acting weird

by superryan14

For the past month or so my printer has been running fine. But a problem I had about 2 or 3 months ago started happening again. My Z axis on my ramps 1.4 AM8 started making a shaking/grinding noise and one side of the axis skips around a bit and lags behind the other stepper motor I have a video of it on youtube here


It will randomly get back to normal movement but then the Z axis is uneven.

I'm not sure if it means my stepper motor is dying or maybe the stepper driver but i'm not too sure what it means. any help would be great.

View Comment

Odd temp errors

by Magic-Goat

So I’m running a good old ramps 1.4 setup and it has worked great until now. It has randomly started stopping mid-print and showing a temp error on either the bed or the hot end. The odd part is that the hotter i have the bed the more likely it is to show the fault 50c and i can usually print for 30-60 mins, 65c and it won’t get past the first layer. If i do not use the heated bed no problem shows at all. Also, if i do not start a print and just leave the printer heating up i never get an error, it’s only once it starts the print.

Error messages that show up:
Error:MINTEMP triggered, system stopped! Heater_ID: bed
Error:MAXTEMP triggered, system stopped! Heater_ID: bed
Error:MINTEMP triggered, system stopped! Heater_ID: 0
Error:MAXTEMP triggered, system stopped! Heater_ID: 0

Again, it seems totally random which error will appear and none of them appear if i do not use the heated bed. All temperatures appear accurate and stable when it stops. I tried swapping the thermistor in the hot end and the errors stayed. I checked all the connectors are secure, wiggled every wire and still nothing.

I thought that maybe the data lines are getting a interference next to eachother so i separated the thermistor bed wires away from the hot end wires but it made no difference.

Anyone seen anything like this before? Any help is greatly appreciated.

For some reason Marlin 1.1.0 wasn't showing the temp drops that would cause the fault. Updated to 1.1.5 and set PID settings for hot end and bed and now works fine. Worth noting that my heated bed is 5mm Aluminum so the PID settings are necessary.

View Comment

HUGE 3D printer concept - how to get over the hurdles?

by Ender3Guy

So, I've decided to build a massive FDM printer. 1000 mm in all directions for build volume. It's also going to be an IDEX system with a remote direct drive extruder on each. And obviously a CoreXY, since anyone who tries to move that kind of heated bed quickly has no concept of momentum.
It will also be enclosed for ABS printing, with an air scrubber using 3M cartridges.

However, there are several hurdles, so I decided I'd come here for help.

First of all, which control boards and firmwares support IDEX setups? I would like a 32 bit processor if possible, preferably with 64x microstepping or greater.
And of course, the heated bed. Does anyone know where I could find a monstrosity like that? Alternately I was considering linking four CR-10S-5 heatbeds together, but it would have ridiculous PSU requirements and probably need two outlets.

Again with the heated bed, I need some sort of build surface that is 1 meter in X and Y axes. I prefer glass coated with an ultrabase coating or similar, though flexible plates are also an option.

Edit 1:
Thanks to everyone who has responded since the original post. The concept has evolved since then:
IDEX platform with dual E3D V6 Gold hotends and 5015s for cooling.
MGN12 linear rails on X and Y axes, with linear rods for the Z.
The X and Y axes will move up and down via four ball screws and four steppers synced with a belt.
A BLTouch or similar sensor will be mounted on one of the print heads for ABL, but the bed will use 3-point leveling and level itself to the nozzle.
Each hotend will have a Zesty Nimble RDD mounted on it.
The aluminum buld plate will be custom machined from AW5083 aluminum to stay flat. Alternately I've been considering steel, though I don't know how that would handle thermal expansion.
The total motors I'm looking at are:
Two leveling motors for the heatbed (I'm using 3 point leveling and the 3rd point will be the reference for the Z offset)
Four Z motors
Two X motors
One Y motor
Two extruder motors
Total is 11 motors. I'm also tempted to add an MMU to one of the hotends which would bring the count up to 13.
An Odroid XU4 will be connected to three RAMPS boards via Klipper to handle the stepper requirements. The Pi 3 or zero are also options, but I would like to have slicing built into the machine, assuming Klipper can do this. If not I'll probably have a Zero running Klipper with an XU4 connected to it and sending over the sliced files.

Update 2:
I've decided that an IDEX system is interesting but not optimal. Instead, I'm going to make a toolchanger similar to E3D's, but not using their motion system. It looks like I'm going to need another RAMPS board!

View Comment

3D Systems Cubify Ekocycle Open Source rebuild

by ndisalvo

I am rebuilding the Cubify Ekocycle for many reasons. First, the extruder is super proprietary. Each filament cartridge has its own nozzle attached to it. The cartridges have chips in them to make sure that the only filament used it their brand (which is $50 for less than a kilogram). Also there is no endstops! The printer moves to home by running the steppers further than necessary and making a terrible grinding noise. I set out to replace all of the annoying bits and upgrade it. I am setting it up to run on ramps 1.4 with marlin. I am replacing all of the parts except for the bed, frame, and steppers.
This is the parts list:

Power inlet and switch:


Ramps 1.4, Arduino Mega, and LCD

Power supply: (no heated bed so only 10A is needed)

Direct Drive Extruder:

Other Parts:
Tons of zip ties
Power cord from a computer
Fans from computer (in addition to salvaged cubify fans)

One tip for anyone that wants to do this-- taking apart the stock plastic case is very difficult. You need 2 hex bit sizes and a small star bit. If you can't get it apart don't be afraid to destroy the plastic case to get it off. It is pretty much impossible to put it back on because the ramps and extruder will not fit

More details and design files will be posted along with pictures once the rebuild starts. I am waiting on the parts to make the mounting brackets.

3D Systems Ekocycle Ramps 1.4 RepRap
View Comment

I present you the MK2 ALU!!

by Durandile

Hi everybody,

It's a first post for me here:

I want to introduce my new printer: the MK2 ALU that I have finally finished after more than a year of work:
It is based on an aluminum frame, so it is highly customizable.
I've tried to document this project as much as possible to allow anybody to build this.

I hope that you'll like it


3D printer MK2 ALU
View Comment