"Failed to parse XML file" message when opening factory file.

Please Login to Comment

Last few days in Simplify3d v4, I've been getting this error or failed message when ever I open an existing factory file:

Failed to parse XML file
Encountered incorrectly encoded content.

After hitting ok for the amount of Processes previsioly created, the factory files opens up. However some of the save settings are missing or revert back to default values: Primary Layer Height, External Infill Angle Offsets, Layer Modifications, etc.

Has anyone come across this message? Can Simplify3d be corrupt? Possibly reinstall it? If so, is there a way to save the "Select Profiles" I have created for different filament settings for my printer?

One note even though I have a few Select Profiles created, and choose the appropiate one depending if I'm using PLA or PETG, I sometimes tweak the setting to better suite the specific model I'm printing: layers, speed, processes, etc. However I don't update the current modified profile. I don't want to update it in order to keep my initial general good settings for a specific filament. Am I doing something wrong this way to create the error/failed message? Thanks.

I think this maybe the issue to my error message. However I recently started using the dregree symble (°, ALT+248)cel in the profiles to spec out the celcius temperature for a particular filament. I updated all the profiles to not include the ASCII for degree. Even though I'm still waiting on results for S3D, it seems to have solve the problem in one new factory file I created. No error came back when I reopened the new factory file with no

Again thanks for all the help. I'll report back if not fixed.

filepaths and filenames with non ASCII characters can also cause this behaviour - e.g. visible when using ö / ä / ü / ß in the file names :-(

Don't use any non-US characters in your naming of processes or anywhere in the job file where you can enter text. Even in the commants after gcodes in the various scripts (process scripts tab) matters. THe XML parser takes a dirt nap when it encounters such characters. It took me weeks to pinpoint.

I had a similar issue with S3D v4 recently using Windows 10.
S3d closed when I tried to slice a model. When I opened it up again, that profile was corruped.
It wouldn't let me change anything. So rather than trust it, I manually copied all the settings to a new profile.
Sure it was tedious, selecting each tab, then switching between the 2 profiles to read then manually enter each setting.
But it worked.
So far it has only happened once, but it does look like there is a bug in v4

I am having the same problem. I am using a Mac so I don't know if there is a bug in the S3D v4.0 or the Mac but I have a saved copy of my FF so I just load it back in when I get the error.

Comments deleted.

I'm using Windows, however with version 3 and upto recently in version 4 I didn't have this problem. Seems when I want to re open an existing factory file to tweak or edit, I get this message with certain settings missing or resetting.

Well if you are using Windows and I'm using a Mac then it is a S3D bug and hopefully they have a fix on the way. I also get it shutting down when I try to slice a part and I have to reset everything back to factory settings and then manually put my settings back in. I guess the long wait for v4.0 should have been a little longer.

Same problem today with my MAC and S3D 4.0.
I've lost all my config :-(
Do you know if there is a plan for a fix in S3D ?

After some tests,, I found why it crashed. Some of my config (gcode scripts and start/end code) included accentuated caracteres, like "é" in French. Looks S3D does not like it that much. I got rid of any special caracteres from my scripts and now S3D does not crache anymore. Good to know.Have fun with your printer