Auto-calibration faulty after 2 years

Please Login to Comment

Hi Guys,

So Back in 2018 I purchased my Tevo Little Monster,
Contrary to many hate posts about the machine I;ve actually been very happy with it,

The only thing I altered on it was the occasional thermistor,

Now 2 days ago the printer started to make a very harsh an agressive sound, as if the carriage was bumping into something,
at first I though this was because I was running smaal/thin prints at 140mm/s
But the sound persisted even when turning the speed all the way down to 50mm/s.

It turned out the X and Y carriages had a bit of play along the C-beam, I adjusted this and did an autocalibration run,
However the bed leveling now is way off, I don;t have any pictures right now, but lets say it prints a circle, starting at the Z-tower CCW, it takes a dip close to the X tower, then rises again between the X and Y towers whilst it prints quite allright on the rest of the bed,

This really puzzles me, I tried recalibrating multiple time,

  • Cleaned the bed meticulously,
  • The end stop probes/set screws are all set within 0.03mm deviation from one another (changing the lengths of these screws doesn;t change anything too by the way).
  • All the bolts on the entire machine are secured.

Could the BLTouch suddenly have broken?
Am I missing something hard-ware wuse, since this occured after altering the hardware...
I never had these problems with it before...

Any thoughts/advise?

I don't have any pictures or G-codes available right now, but if needed please let me know and I'll supply this ASAP

You didn’t mention this, but I am sure you have done: are the belts tight, so they “twang”, if you pluck them?

Also, is the probe on the BLTouch straight, and intact? I have had a metal probe that once got kinked from the carriage crashing into the plate (had wires back to front). Some of the newer, plastic ones don’t look very strong to me, either.


Thanks for the reply and the suggestions,
Yes I did, the belts should be tight, I've never had an issue with layer shifting.

And as far as visual inspection can tell the probe looks okay, I have ordered a new one just to be sure as I did have a printer crash a while back.

But it's strange I've been running the same G-code for hours on end now (I'm printing FaceShields) and all of a sudden prints start lifting fromt the bed and the printer won;t auto-calibrate properly anymore (after just printing fine in the previous print) with prints actually lifting in one place and the nozzle almost crashing into the buildplate only 5~ cm further...

I checked if my bed was flat, it was. I even applied the bed-sticker that comes with the Little Monster (I never used it before because I prefer printing on glass), re-calibrated, but still the same outcome...
It's almost as if calibrating doesn't make any differences anymore regardless of endstop position or how clean or cluttered the bed is.

Maybe its time for a long awaited conversion to Marlin? The printer is 2 years old after all, it could be that the board finally gave in?

For now what I'll try in the following order;

  • Write a new test G-code, manipulate the Z-offset in Cura to see if I can create a temporary emergency fix (it will print too close to the buildplate in some spots, but if it stops prints from warping loose this will do for now.)
  • Manipulate the endstop positions and see if this is the problem/solution after all (Would changing the optic endstops for mechanical ones change anything?)
  • Ordered a new BLTouch (any better suggestions for a BLTouch perhaps?)
  • Create a 'ghost' in Marlin (Hooking the current hardware up to a RAMPS flashed with Marlin set up for the LM and check if a similar issue persists)

When removing the sticker from the bed earlier today, I came to the startling conclusion that the glass plate was loose...
this led me to and idea;

I autocallibrated the bed as usual, then identified the low and high spots and used shims under the glass plate (layers of A4 paper) to ever so slightly tune the bed,
This seemed to work, I then tried to autolevel/calibrate the bed again, excpecting it to be janky after. It was! Only with a very random pattern of low and high spots... The previous pattern was somehwat logical with low spots starting at the Z tower leading up to high spots at the Y tower, pretty much in a straight line between the towers.

Then I deduced the BLTouch probably is rekt, but I needed this printer working ASAP.
So what I did is that I replaced the 6 M5's, which bolt the bed down with longer bolts and the spacers with sturdy springs so I could at least get it to print whilst leveling the bed manually, even though this really is an emergency fix...

This worked, but I figured I'd autocallibrate the bed and see if I could get a better 'random' pattern saved in the EEPROM, because the current pattern was hard to tune, even with 6 adjustment points.
When doing this however, the nozzle crashed into the buildplate.

The buildplate has risen roughly 8mm in relation to the old set-up, I measured the old set-up with aluminium spacers these measured around 12mm give or take 0.1mm. The new distance being somewhere close to 20mm.

Can anybody explain why this happens? Because when I run a print it just works normally.. No crash..
I do use a G30 command at the start of each print instead of a G29, is G29 somehow different besides the number of probing points?
I am using the original stock smoothieware that came with the printer originally by the way.

For now the machine is useable, but I really want to find an adequate solution to this...

Below is the start G-code for the printer, which I got from a lovely contributer 2 years ago;
G28 ;Home
G92 E0
M280 PS3
G28 ; home all axes
G1 Z50 F25000 ; lift nozzle
G30 Z0.975; my nozzle height - the higher the value, the smaller the distance from nozzle to bed
M280 S7 ; Lift BL Sensor