Loading

Recent Topics

Overview

by hastla

Tutorials, parts and other infos for TEVO Tarantula

Best is to join the owners community here on fb - really helpfull people & pics of prints: https://www.facebook.com/groups/TEVO.3dprinter.owners/

...............................................

-> Where to buy the printer?

Recommended is to buy direct at the producer - links and different version here: http://pastebin.com/38FnD9F4
...............................................

-> Tutorials

There are in general 2 build video available (02/2016). Soon there will be one available in German too. So download the 2 pics here for zooming in plus look at videos linked down.

TEVO printed tutorial: http://imgur.com/a/IMw9R

...............................................

-> Videos

Build video by ArcadED (best of all):
https://www.youtube.com/playlist?list=PL7OGtDmFA6R6nBhSznM8lyO57RcmNu6Vk

TEVO original (no audio):
https://youtu.be/aU-kl5_rK8M

...............................................

-> Addons & parts to print

...............................................

-> Firmware

An updated community firmware can be found in File section of "TEVO Tarantula Owners" group on fb (link above).
...............................................

-> Replacments list

...............................................

More coming soon!

View Comment

TEVO does not reply to my messages about a broken motherboard

by xblaauw

Hey, this is my first time here, i bought a TEVO Tarantula in September of 2017, assembled it, and it didn't work. I assumed it was my prob so i broke it down and rebuilt it, still nothing. I ran out of time to work on it and shelved it for a few months. About a month ago i pulled it out again and deduced that the error originates in the extruder motor port on the motherboard. It violently spins the extruder motor in both directions (alternatingly). So i thought, there are 2 solutions: First, i should be covered by warranty (i'm in Europe, so 2 years on all electronics), however the people at TEVO do not respond to my tickets, requests to chat, messages on Aliexpress, anything. Second, the motherboard has a second extruder motor port, for dual extruder operation. I do not plan to use this machine with a second extruder ever, so i would be fine with using this as the main extruder port. But i am not able to find out how to accomplish this.

Does anyone have any experience getting a replacement part from TEVO? How did you get their attention?
Does anyone have any experience switching the extruder motor ports on the motherboard?

Thanks in advance!

broken_parts contact Extruder_Motor extruder_motor_port motherboard support TEVO Tevo company tevo_tarantula warranty
View Comment

hotend nozzle won't heat up

by amnond

I just completed building my Tarantula 3D printer and did some temperature tests.
I've carried out the nozzle test Control->Temperature->Nozzle, increased the temp to above room temp, the nozzle does not heat up and the info on the LCD shows it stays on 19 degrees.
I checked the wires, they are connected fine.
if that helps, I tested the bed temperature and it is working fine.
Am I missing something?
Thanks.

View Comment

my new tarantula, no stepper motor is moving

by kwietsch

hi all, i have a problem with my new tarantula. none of the stepper motors are working. if they have to run they are stucked in the actual position. all signals are fine. does have anyone any i idea?

View Comment

Printer stops printing suddenly

by Roichu

It happened 3 times in a raw. Yesterday it was printing well but today it stops printing in different heights. It does not show any message of error. It performs homming well. The stls that y was trying to print was printed succesfully a couple of weeks ago. I don’t think that it’s a problem with Cura, because there were no errors (as long as I can tell) and the SD card was removed securely.
What is happening on my printer?

error printing_problem tevo_tarantula
View Comment
Top