Loading

Recent Topics

Overview

by hastla

Tutorials, parts and other infos for TEVO Tarantula

Best is to join the owners community here on fb - really helpfull people & pics of prints: https://www.facebook.com/groups/TEVO.3dprinter.owners/

...............................................

-> Where to buy the printer?

Recommended is to buy direct at the producer - links and different version here: http://pastebin.com/38FnD9F4
...............................................

-> Tutorials

There are in general 2 build video available (02/2016). Soon there will be one available in German too. So download the 2 pics here for zooming in plus look at videos linked down.

TEVO printed tutorial: http://imgur.com/a/IMw9R

...............................................

-> Videos

Build video by ArcadED (best of all):
https://www.youtube.com/playlist?list=PL7OGtDmFA6R6nBhSznM8lyO57RcmNu6Vk

TEVO original (no audio):
https://youtu.be/aU-kl5_rK8M

...............................................

-> Addons & parts to print

...............................................

-> Firmware

An updated community firmware can be found in File section of "TEVO Tarantula Owners" group on fb (link above).
...............................................

-> Replacments list

...............................................

More coming soon!

View Comment

Change hotend voltage in Marlin from 24v to 12v?

by Krytern

So I know you can effectively change the fan voltage using FAN_MAX_PWM but is it possible to do it with the hotend?

View Comment

Tarantula failing mid print - advice please

by Mick_Tarantula

Hi Guys,
my Tarantula has suddenly started stopping randomly mid print. I am using stock board and firmware, and recently replaced a faulty x endstop, but all has been working well.
When it stops, it appears as if the board/lcd has frozen. The screen still reads printing type data, with temps as they would be by setting (200 ish hot end, 60 ish heated bed). I am not positive, but I think it can also heat above those values without displaying it, which is a bit of a safety issue (I turned off and back on and got a clean read from the hotend thermistor above the set value on one instance).

After searching a bunch of forums, I have tried different SD cards, different slices of the same object, and using different sliced objects.
I tried a new lcd/card reader (had one lying around spare) with no change in result. I also upgraded my slicer (CURA), then set it back a bunch of versions and tried again but still no joy.

I am at the end of my ideas of what to change/check, so would love some advice on what to try next if anyone has any ideas.

View Comment

Z-axis expansion.

by Paul_Hanson

Hey Guys, I do believe that the HE3D EI3 is a clone of the Tarantula.
My HE3D was supplied with one 380mm threaded rod, I have since added the dual axis upgrade.
One of the things I desired was to make taller prints and I started examining my machine.
I noticed that about 60mm of threaded rod is below the brass nut and has in fact never seen any action ever, I considered replacing the vertical parts of the frame with longer peices and priced up the extrusions, they came to about £20 depending on where purchased.
Then I remembered that you can 3D print the extrusion profiles, So I produced one 60mm heigh 2020 and one 60mm heigh 2040 and some joining parts, all from the just another (size) extrusion designs here on Thingiverse. I fixed them at the top of the aluminium verticals all that was needed was a bit of hotglue to hold the joiners in place with the printed extrusion. The fit was almost perfect to the aluminium.
My HE3D now has a print height of 270mm and works fine. It's the best mod I've done to it. I printed a 270mm heigh Aria the dragon and it's just amazing to compare it to a 200mm heigh model of the same type.
I have modded my HE3D quite a lot but it was initially constructed as a tripple nozzle EI3 but gave up on multi extrusion and bowden.

HE3D_ei3 tevo_tarantula_mod
View Comment

Calibration Issue - Need Advice

by Tarantula_of_Arizona

Hey everyone, I have a new TT Pro as my first printer and I printed my cube as we do. You can see in the photos X:20.3 Y:20.3 and Z is incredibly perfect almost 20.0

I have moved on and printed other things too, but whatever I print, it's always 0.3 mm bigger and the holes are smaller as a result. I tried to print a 0.8mm thickness wall (0.4 Nozzle) but it always come 0.2mm thicker and ends up 1 mm. Which makes sense, the whole body is always 0.3-0.4 mm wider then it meant to be. I checked the extruder for calibration with a 200mm mark, it seems fine.

I print PLA, 0.4mm Nozzle, 0.2 mm Layer Thickness, 0.8mm Wall Thickness
Generally %50 Infill or higher (I need strength)
Sliced at Cura
200-210 Hot End, 50-60 Bed Heat
40-60 mm/sec Speed
%50-80 Fan Speed

Should I play with steppers or is it a software issue?

Thank you in advance!

View Comment