Loading

Pinned

Overview

by hastla

Tutorials, parts and other infos for TEVO Tarantula

Best is to join the owners community here on fb - really helpfull people & pics of prints: https://www.facebook.com/groups/TEVO.3dprinter.owners/

...............................................

-> Where to buy the printer?

Recommended is to buy direct at the producer - links and different version here: http://pastebin.com/38FnD9F4
...............................................

-> Tutorials

There are in general 2 build video available (02/2016). Soon there will be one available in German too. So download the 2 pics here for zooming in plus look at videos linked down.

TEVO printed tutorial: http://imgur.com/a/IMw9R

...............................................

-> Videos

Build video by ArcadED (best of all):
https://www.youtube.com/playlist?list=PL7OGtDmFA6R6nBhSznM8lyO57RcmNu6Vk

TEVO original (no audio):
https://youtu.be/aU-kl5_rK8M

...............................................

-> Addons & parts to print

...............................................

-> Firmware

An updated community firmware can be found in File section of "TEVO Tarantula Owners" group on fb (link above).
...............................................

-> Replacments list

...............................................

More coming soon!

View Comment

Marlin Easy config Auto Bed Leveling not working correctly. Help

by RamJam

Hi guys,

I cannot get the auto bed level on my Tevo Tarantula to work correctly and after a few days of trying to sort it I just cant work it out.
I've set the outsets for my 3d Touch probe, it homes all axis (x,y,z) correctly when sending a G28 to the printer from Cura. However when I send a G29 after for the autobed leveling to start, the probe extending and the z axis starts to move down but stops and retract the probe before it ever touches the bed like it does successfully with a auto home.

Am I missing something in configuration h?

Any thoughts?

Cheers

View Comment

So what happened to Tevo.....??

by James_R5D4

Hi all, as the title asks.....??

Recently spoke to a YouTuber friend [3D printers] who told me what he'd heard lol.

View Comment

Z- port not working

by paulorfo

Hi everyone.
My Z endstop is not working anymore. I'm pretty sure the problem is the Z- port where it is normally connected.
Can I use the z+ port?
If yes: what do I have to change on the FIRMWARE?
I'm using Jim Brown's marlin firmware.
Thanks.

View Comment

Original Firmware for tarantula pro

by JarlVeni

Hello,
I can't find the original firmware that came with the tevo tarantula pro any where online. Does any one else know where to find it or still have it and could provide me with it? Thank you in advance.

View Comment

Problem printing things with large area

by CrazyFlamingos

Hello, I am experiencing a problem with my printer where if I try to print something that encompasses most of the bed, the infill doesn't print properly and starts running into one corner while continuing normally on the opposite side, causing a bunch of material to accumulate and the print to fail.
Tool path has no issues in the slicer and there are no other problems I have experienced regarding quality, so I have no idea what the problem could be, any help is appreciated.

View Comment

Exchange power supply for Tevo Tarantula printer

by crudolf

I bought a new power supply: Thermaltake Smart RGB 700W. According to this video I would just rewire the cables to get it working with my Tevo Tarantula printer.

https://www.youtube.com/watch?v=SBhlHQbUaqs

Do you think it will work? Do I need to expect anything? Will it work? :D Is there anyting that I should take care of before trying it out?

View Comment

Board replacement recommendations

by Exhumation

Recently I tried to reactivate my Tarantula after two years but ran into problems with the stepper drivers.
Two of them didn't work.
So I'm looking for an replacement board which is similar to configure, also runs Marlin and in the best case has better stepper drivers or replaceable ones.

Any Ideas?

printerboard stepper_driver stepper_motor tevo_tarantula
View Comment

What to do with new Homers tarantula

by dantimdad

I bought the kit, assembled it and now I have too many printers. (I already have 5)

I actually thought about converting it to do laser engraving or some such or just selling it cheap.

Any ideas?

I need to stop impulse buying printers! LOL!

View Comment

bltouch on TTP

by chimera254

After upgrading to a bltouch probe on the TTP I have got the printer to home in x,y,z but when the bed levelling runs the probe seemd to be offset in y and missing the bed at the rear ive tried the offset in the FW but still no luck in solving the issue the probe is located in the default postion behind the hot end

View Comment