Loading

HOW TO CHANGE E0 TO E1 MARLIN 1.1

Please Login to Comment

I have the same problem as here https://www.thingiverse.com/groups/tevo-tarantula-owners/forums/general but i don't have those lines in my RAMPS.h file http://joxi.ru/DmBgR75UNe8k52.png.
I've recently burnt my potentiometer on E0 so the motor isn't working properly anymore. I want to to use it on E1 instead. If you have any better idea how to fix this instead of changing code in firmware, feel free to share.

You can swap pins in pins_RAMPS.h of Marlin firmware as in the picture attached.

The problem is that for some reason i don't have those lines in RAMPS.h. Please, help me :) I am using latest firmware downloaded from here https://tevonewbieguide.weebly.com/latest-firmware.html

I'll try to download this firmware https://github.com/JimBrown/MarlinTarantula. Maybe that will do the job.

It is in pins_RAMPS.h, not RAMPS.h. See attachment.

I understeand. I just called pins_ramps.h just ramps.h. Now i've downloaded this firmware https://github.com/JimBrown/MarlinTarantula and it has such lines, but now I can't get it to install properly and get an error in arduino IDE http://joxi.ru/J2b6n9whXpYy02.png

PC or Mac? Did you install the usb driver? Did you connect to the right com port? I found this doc for installing the usb driver on PC. http://www.elf-games.com/tevo/usbdriver.pdf

PC. ok, I'll try. Yes, right com port.

UPD: i've just booted up printer and it seems like it has new firmware installed. It is strange that it was not installed when i tried it previous night. And the motor is still not working.

here's how my changes in code look like http://joxi.ru/vAWX54BI1wlRor.png. I swapped all E0 and E1
extruder is in the E1 slot on the motherboard

I found the USB port is not reliable, and you might need few try to get it to work. I will try to reboot the computer without any other programs running first.

Windows also shows an error like this device can't be used with usb 3.0 but it is plugged in usb 2.0

Interesting! I used an older laptop with Windows 7 and Mac to program this board. It failed 50% on Mac, but it will eventually work. If you can't get it to work, you can also program it via ICSP port on the board.

Oh! And one more thing. The funniest here is that i can easily install other firmware versions, but not this one

Ok. Stay tuned. I'll try some more ways to solve it and will write it there.

I can also send you the configure.h file I used with Marlin 1.1.8.

I am still waiting for your file:)

I message to you via thingiverse

ok, that would be cool

Maybe my printer somehow does not support latest firmware? :D. I can't install latest firmware from tevo page and from marlin page, but i could install an older version of marlin that one guy gave me. Anyway maybe if you will send me your configure.h file it will help

Or just can you send me your whole firmware? :D

Comment has been deleted