Loading

thingiverse not generating images of STL files

Please Login to Comment

it used to generate images my Files now it does not, even deleted and re-uploaded a couple of ones that it did generate in the past just to see if it was my new files and it won't generate the ones I re-uploaded, is thingiverse no longer able to do this feature?

Did you ever find a fix for this? I'm having the same issue in Nov 2020, with my uploaded things not getting STL generated

Ditto, a real PITA

Same Problem here:
I have deleted and readded the stl-files several times, but no change...
https://www.thingiverse.com/thing:4639565

Halloween pumpkin cookie cutter
by rgrae

Also not seeing a preview for this thing either:

https://www.thingiverse.com/thing:4621185

Dremel Router Circle Cutter

My thing doesn't have a preview either.

https://www.thingiverse.com/thing:4623125

Shower knob for 12-point stem

I'm having issue with STLs uploaded and not showing the preview also. Tried the save, edit, delete, save, edit, add, save and it didn't work.
https://www.thingiverse.com/thing:4622238
thanks

Commodore 64 Dead Test Shell or Case NB HighTech version

It is still an issue. Any idea what the problem is and when it should be fixed? This looks like it's been going on for months.

I have the same problem on STL file but also on PDF file :-(

https://www.thingiverse.com/thing:4611772/files

Double extruder for CTC 3 pro or AM8
by jiemeb

Still an issue, I think. I have uploaded several files recently and none have previews of the STL

Still the same Problem. Removing then re-adding the files doesn´t help (makes it worse). https://www.thingiverse.com/thing:4594792

Toaster gun Junk Yard Pinball Mod

This problem still appears to exist. My 3 new STL files on https://www.thingiverse.com/thing:4134488 have no generated images.

Wireless Midi Footswitch Pad (Bluetooth/BLE)

Yep, same here. It sometimes generates them and sometimes not. My project last week was fine. Today it will not load. Still bugged...

Thanks for reporting this issue.

We've identified the root cause and issued a fix. New Things should have STL image previews generated, and we will be going through the backlog to see which Things do not have an STL preview so we can manually trigger preview generation for those. This should be done by the end of the day today (Eastern Time), but it may take longer.

If one of your Things still does not have an STL preview in a few days, please PM me the link to that Thing and I'll make sure it gets fixed :)

Hi TJ, this is still an issue (at least for me) in Nov 2020 when uploading things. I've PMed you. Thank you

Same problem here
https://www.thingiverse.com/thing:4656956
https://www.thingiverse.com/thing:4635759

Is there a trick to generate previews? Maybe by using another application and upload them separately?

light webcam mic modular desk mount
by andzer
lamp shade ceiling fan lantern
by andzer

Hello,

I have this issue on everything I try to post.

No STL preview on this:

https://www.thingiverse.com/thing:4575700

ans this:

https://www.thingiverse.com/thing:4615945

Is there any way to fix it?

Thanks.

PS: I also can't see my "makes" in my profile.

E-Flite F-18 AIM-9 Sidewinder Weapon
Smaller central part for Modular Mini Tripod

I'm still seeing issues as well, I also tried "fixing" the models in netfabb just in case.

https://www.thingiverse.com/thing:4563291
https://www.thingiverse.com/thing:4586593

Edit: One of three models did generate a preview! Though 2/3 of the fixed ones have not, and the non-fixed ones haven't (it'd be ideal if the preview generator could figure it out on its own).

Eufy Camera Dog Crate Mount / Holder
Pax Era / Pro Tile Sticker Attachment

It's happening again. PS that cap on photo size is a real pain as well. I've started posting photos elsewhere and providing links rather than bothering with the hassle of shrinking images to fit your new limit.

I agree, if they want a storage limit why not allow full-size upload and compress at the server to save the user the trouble? Or there's probably ways to even compress before uploading.

I have like 5 new things with the same problem. I hate this new version of Thinguiverse.

I totally agree with you about the new version. It really seems not polished yet... The website takes forever to charge (and it's not my connexion), half of the time the search results don't display, or on an object, the image will indicate loading but take a good 30 seconds (for a picture... that's not normal), or even sometimes never load !

And I also have the same issue with a new thing, where it doesn't generate thumbnails :s

I have new things still does not have preview generated.

https://www.thingiverse.com/thing:4230799

Thanks for your help!

Mask Case

I tried re-adding some files but its not working. Please trigger the thumbnail generation for STL files.

https://www.thingiverse.com/thing:4245846

Face Shield with Sealed Top (Foam Tape + 3-hole punch)

Hi,

re add has not worked. Images are not generated, thing is not to find by search...

https://www.thingiverse.com/thing:4118684/files

Greetings Andreas

Ubiquiti Unifi AC Lite Stand
5-15V 2A TP5100 18650 fast Charger -- 5-15V 2A TP5100 18650 Schnelllader
12V-48V 20A induction heater with water cooling Kit -- 12V-48V 20A Induktions Heizer mit Wasserkühlung Set
5-15V 2A TP5100 18650 fast Charger -- 5-15V 2A TP5100 18650 Schnelllader
12V-48V 20A induction heater with water cooling Kit -- 12V-48V 20A Induktions Heizer mit Wasserkühlung Set

Is there a way to trigger the STL image previews aside from sending you a PM? Have a couple things that still need it and don't want to bother you with all of them if I can re-trigger it myself. Would removing the STL and re-adding it be enough?

I believe removing then re-adding the files should do the trick, yes. But if that doesn't work, you can always just PM me - it's no big deal really :)

(We are still working through the backlog of STLs that didn't render properly, so they should all be fixed eventually.)

Same here: https://www.thingiverse.com/thing:3974307
tried to re add a few times, but didn't helped

Raspberry Pi 4 Enclosure with 2,5" SSD/HDD Mount

Same Problem , delete the STL and added again will not fix the Problem.
https://www.thingiverse.com/thing:4283052

Lochreihe (System 32) Adapter für Makita Führungsschiene und Fräße RT0700

Hi. I'm getting the same problem on a new thing: https://www.thingiverse.com/thing:4200863/files. Removing then re-adding an STL made no difference...

Cartesian Plotter v3

removing/readding did the trick, thanks!

Adding and removing has not worked for me on 2 of my things:
https://www.thingiverse.com/thing:4284735
https://www.thingiverse.com/thing:4284735

X822 Reference Model (GeekWorm / SupTronics)
by Neckoz

You probably need to save the thing in between removing and adding: remove the STL, save the thing, upload the STL, save the thing. You'll need a second STL in the thing so that there is always an STL left in the thing when saving. The time of day may be a factor that affects the chance of success; if it doesn't work, try again several hours later.

Yeah, I've tried all that over 4 days now and still nothing.

Well, it used to always be a hit or miss thing whenever previews/Thingiviews for STLs weren't being generated, so retrying until it worked was always effective.

However, now it looks like NO STL previews have been generated since about 18:00 GMT 2020-04-15.

You can check the firehose page to see when STL preview generation is working again; the firehose page always has several customized models and if their STLs have a preview image then it's working again. If you see only one or two that have STL previews they may have been generated before the date mentioned above and the creator didn't publish their thing until shortly before the time that you check the firehose page. You can check that by clicking on the thing and then going to the Thing Files tab and looking at the date that the STL file was uploaded.

https://www.thingiverse.com/explore/firehose/

Just made thing https://www.thingiverse.com/thing:4557410 and it made a preview of only 2 of the 6 STL's.. I snapped a pictures of my Prusa Slicer bed loaded up with all of them, as an example, tried to make that the mail image.. also fail.

No one knows what my thing looks like...
Nellson's MPCNC Primo Cable Chain Mounting Kit
by nellson

Having a he pre image of the drawing gives a 360 view plus some of the prints are pretty rough that the picture of them doesn't give a accurate representation of the file

It's not fixed as well as you think, or else it's broken again already. New customizations (created within the past hour) of my Customizable LEGO compatible Text Bricks (remixes) have not had the STL image previews generated.

Customizable LEGO compatible Text Bricks
by Lyl3

Thanks for pointing this out, we'll take a look.

I kind of like it that way.

It's easier to filter out the things without makes.

You could also use the "Has Makes" refinement in search:

Hi I am getting the same problem as my thumbnail images are not show on my profile however it mentions that the STL files have bee n uploaded , Please can you help. This is my account... https://www.thingiverse.com/raf-k-81/designs

And this is the file not show any thumbnail images... https://www.thingiverse.com/thing:4576469

Many Thanks

Raf

Stylized Skull Yo-yo

On the tangential topic of "Has Makes". Many people include their print with the published materials (that is what I have been doing), while some post the make of their thing after the initial publish. What is the "correct" standard?

For consideration: A flag on the publish if you made and tested the thing.

Historically I have personally been including pictures of the finished prints along with the Thing instead of posting it as a separate Make. I don't think there's any "correct" way to do it, though. If you want to maximize visibility of your Thing, you could post the pictures in your Thing and a Make, so it'll show up regardless of whether that refinement is selected.

We'll consider making this clearer in the future; thanks for the suggestion!

Chill, shit happens, it's just bugs and they will sort it eventually/
Do you think they would abandon the whole thing because of a bug?

maybe you should listen to your own advice and calm down, this has been a ongoing issue, I am just wondering if it beyond their capability to have it render thumbnails and not run slow

This comment is currently flagged for moderation.

and yet here you are

Its like that since many days now! I uploaded new thing last week, but no preview for STL files! BTW, Thingiverse is working much better than before; not slow any more. I hope, they will fix this little problem soon.

It's possible generating the STLs was making it slow, so they temporarily turned it off.

that is what I am thinking as well