Loading

Error while opening shared libraries

Please Login to Comment

Opening Customizer for any customizable object for the last week or so gives me the following error: "/usr/local/bin/openscad/openscad: error while loading shared libraries: libCGAL.so.10: cannot open shared object file: No such file or directory"

Not sure if this is Thingiverse or me. I'm using the latest version of Chrome on 64bit Windows10 when doing this. Pretty sure /usr/local/bin is a linux directory.

Still happening, are they not even trying at this point?

We are not going to solve the fundamental problem sitting at our computers, remote from the servers. What is needed is a complete re-upload of the Customizer resident files. The reason I suggest this is that it is possible that it is not the file that is missing, but that it has been misnamed elsewhere in the software. Trying to identify where in the program the error is might take weeks. Re-uploading would take very little time, assuring that there is a working backup available.

Anyone have any luck on a solution here? Still getting that error.

Problem persists.

I don't think I can really be bothered to continue with Thingiverse. Their working on the site didn't work. They obviously couldn't care less.

If you are really in a pinch and can install the OpenSCAD IDE, then checkout the video I linked to below.

It is a walkthrough of using the offline Customizer built into OpenSCAD.

I've done both of those, thanks.

Same here, still an issue.

https://www.thingiverse.com/apps/customizer/run?thing_id=1367661

/usr/local/bin/openscad/openscad: error while loading shared libraries: libCGAL.so.10: cannot open shared object file: No such file or directory

Would appreciate at least a response from the Thingiverse team...

Looking back on what I have done on customiser, the last time it worked for me was 18th January, I wonder when it actually stopped working. Initially I didn't get error reports, that only happened a couple of weeks later.

Getting the same error...

In case you want to try the offline version, here is a video walk through of using the Customizer in the nightly build of the OpenSCAD IDE with customizable things from Thingiverse.

https://www.youtube.com/watch?v=knKgMEod11U

Awesome Thanks. This works great!

Same here.
No one from Thingiverse will solve this?

A mí me pasa lo mismo.
Nadie de Thingiverse va a solucionar esto?

What I find disheartening is not only has this issue persisted since September of 2017, MakerBot has not even replied to any of the posts about the issue. Has anyone heard or seen a post from MakerBot regarding Thinkiverse in the last 6 months?

Still broken. I posted my first Customizer project and while it works in OpenSCAD it fails in Thingiverse Customizer with:

/usr/local/bin/openscad/openscad: error while loading shared libraries: libCGAL.so.10: cannot open shared object file: No such file or directory

Thing: https://www.thingiverse.com/apps/customizer/run?thing_id=2781404

Hola a todos. En Colombia también sucede. Usando Opera, Google Chrome y Firefox en Windwos 7 Ultimate 64 Bits.... el mismo error: /usr/local/bin/openscad/openscad: error while loading shared libraries: libCGAL.so.10: cannot open shared object file: No such file or directory.....

Anyone have any updates as this is disappointing....

I raised this too a few days back, no acknowledgement. Annoying thing is I want to do some mods to things I have previously customized and published.Happens in all of the browsers I use, seems like there is a missing file on the host server. I agree about it probably being a linux based system.

You can download the scad file and alter the variables yourself in OpenSCAD.

I didn't have OpenSCAD, I do now and I've done just that to a couple of things. Thanks for the suggestion.

yep still happening

Same for me... In firefox...

It's the same for everyone, regardless of browser. Why Thingiverse hasn't acknowledged this is beyond me.

Still happening today. I just uploaded my first Customizer design and it gives that exact error.

Yes that is a *nix type directory structure. My guess is that something botched the OpenSCAD install they're using for Customizer. Hope it gets fixed soon.

thingsgiverse had some (very minor) hickups last week. Obviously hosted on linux platform, that is linux platform errors you saw.

Still happening today

Would be nice if someone from Thingiverse would acknowledge this issue.

I totally agree. It is very unprofessional and shows lack of interest about what is going on here.

I find it very strange this is not a bigger concern for them since the Customizer capabilities are so important to the novice 3D printers and CAD challenged public who are some of the main users of Thingiverse.

In the DIYRoboCar/Donkey build channel of Slack, so many are having problems finding the one RC vehicle which fits the build plate I decided to reproduce the plate in OpenSCAD and enable Customizer customization to more RC vehicles could be used by just moving the mounting hole positions. IMO a perfect fit for Thingiverse and will expose a new set of makers to the platform. If they ever fix the problem. Otherwise, I'll start directing people to install OpenSCAD locally.

As previously mentioned I have already installed OpenSCAD, the problem is that some designs aren't too easy when it comes to finding the variables. Customizer is a brilliant idea when it works, I have customized dozens of things for my own purposes, and some of my customized things have even been downloaded by others. It is of course a great tool for newcomers to 3D printing, and for Thingiverse it is what in retail we call a USP, giving a major advantage over other libraries of things.