Loading

Unable to publish new thing.

Please Login to Comment

The thing page says "This thing is not yet public. You must publish this thing for everyone to see it." I click on the hyperlink to publish, it takes me to the eit page. I click "publish" and the page looks like it just refreshes. It will not publish. When I look at the edit page, nothing seem like it is telling me there needs to be more information and no alerts.

What gives?

Created this thing:
https://www.thingiverse.com/thing:4686209
But its not listed in my list of things. My list of things says I have 5 things but only shows 4 (not the one above)
Do I have to click a publish button or something to make it public?

SR Logo

Due to yet another another Thingiverse bug, it's now a good idea to save any new thing and make sure it shows up on your design page before publishing. Clear your browser cache before refreshing your design page to make sure you're not seeing a cached version of the page. If it doesn't show up, delete it and try again.

See the following post for more details:

https://www.thingiverse.com/groups/thingiverse/forums/site-issues-and-feedback/topic:48627

I also have this problem for One month, does anyone know how to solve it?

Have you tried creating a new thing or are you just repeatedly trying to publish the same thing?

I tried uploading two different models (stl) twice and the effect was the same. (I have also used my friend ’s account for the same operation, but it ’s no different)
My steps are uload a thing ---- fill the info and file ---- save and public
After completing the information, there is no error prompt in the system. It will pop out of the publishing interface.
But it still shows unpublished on my homepage. When I click Publish again, I will enter the editing interface again. Repeat the previous operation again.
Is there anything missing from my operation? I'm confused now.

I don't know what your steps are. You wrote "My steps are uload a thing ---- fill the info and file ---- save and public". Are you using an app? Because those words aren't even in the web interface.

These are the steps I use:
1) After uploading one or more STLs and optionally some pictures, click the "Save & View" button.
2) View it to make sure everything is correct and ready for publication.
3a) If it doesn't all look good: click the "Edit Thing" button, make changes, click the "Save & View" button, and go to step 2.
3b) If it all looks good: click the "Edit Thing" button and then click the "Publish Thing" button.

It might also be the time of day that's causing the problem. I've recently noticed that every day at exactly 00:00 GMT the servers become overloaded and some things don't work. It then takes several hours for the servers to start functioning normal again. So for the highest chance of success you should probably try as close to 00:00 GMT, before that time, but not after. So 23:59 is the best time of the day, and one minute later is the worst time of the day.

My operations are all carried out on the webpage, not in the app, probably as shown in the picture.

So, those aren't the same steps as I use. You're skipping the step of clicking the "Save & View" button in my step 1. Maybe that's why I haven't had a problem and you did.

I also notice that your model was uploaded on Feb 26. That's two and a half weeks ago. So have you tried your step 1 more recently than that? If not, then maybe you should. There might have been a problem when you created your thing and it will never be possible to publish it. Try creating a new thing right from scratch starting with your step 1 and don't skip clicking the "Save & View" button. If it works then delete the thing that you've been unable to publish.

Edit: I just noticed that the file shown in the step2fillinfo.png image is a ZIP file. You do have an STL that's not zipped, right? Because if not, then that's definitely the problem and you will not be able to publish it.

OK, I'll try it, what you said.
Thank you in advance

Note that I edited my last comment with some important information.

The displayed picture (png) is not compressed.
But the stl file is compressed into zip or rar format

That's definitely the problem then. You can't publish a thing without an STL file. A ZIP file is not an STL file even if it contains an STL file. You must upload an unprocessed STL file.

This is still going on, has anyone heard from them about an update?

Are they still working on this? I'm having the same issue with https://www.thingiverse.com/thing:4216067.

Dungeonsticks Forest
by Gtrtek

I'm not sure... I hope so because this has been happening for more than a month. They need to fix the preview and publishing glitches ASAP.

I have been trying to publish a remix and I am having the same issue.

The same with https://www.thingiverse.com/thing:4208661

This has been going on for weeks. I can't publish anything

Could you link me to the Things you are trying to publish? We're aware of this issue, but we haven't been able to reproduce it ourselves, so we need as much information as we can to find out exactly what's causing it.

Thanks!

https://www.thingiverse.com/thing:5338698
https://www.thingiverse.com/thing:5330551

The only way I even have any way to see these is because when I first created them I saved the link to put in the readme on github. If I had not just happened to do that, these would just be lost in an unreachable black hole. There would be no way I can find to ever find them again. Serching by the tags or title doesn't turn them up. Even my own "My Designs" page does not show them. It says "5 designs" but only 3 older ones show up.

However, since I did save the thing# when it was created, I can go to the thing and it does recognize that it's mine and lets me edit it.

Baggie Drying Tree
by bkw
PiZtand
by bkw

Problem still exists sadly! https://www.thingiverse.com/thing:5437758 doesn't show anywhere, but oddly has appeared in my linked Cults account! Go figure.

Shelf hanger for Office cabinet
by GSV_NFA

Here's an example:
https://www.thingiverse.com/thing:4634104

It doesn't show up under my designs, and the only way I can access it is to use my browser history. There is no way to access it from the site main page or from my user page.

Creality Ender 5+ Bed Leveling Knob & Indicator Set

I don't know how to link, but my STLs sometimes turn into blue thingivue pictures but sometimes only blue but no thingivue option and sometimes no picture despite being available to download. My thing is "Flying Scotsman 60103 N Scale (Not powered)". I have attached the two STLs that didn't show in the display at all.

Could it be that the "published"-status is not read back from the database correctly?

I just happened to have a look at my statistics and there it says "Published on March 6, 2020" for https://www.thingiverse.com/thing:4204735

Maybe the thing has its "published"-date set on creation and that somehow prevents it from being published correctly afterwards?

That would be my first guess...

I've had this issue with 4 test things in a row this morning but others seem to be able to publish things as normal,
which to me suggests there's something wrong either with the web cluster or with my account.

Bacteriophage Kit for Corona Beer Bottle

Any updates? This affects more than one member.

Comment has been deleted

I just added an STL to my thing and I can't see any "publish" button any longer. All I have is "save and view", even when clicking that it does not show a "publish" button.

I had this too, for a while! But then it somehow went away, perhaps after complaining here. But this was on the "old" site design. A month old, I mean. Things change too quickly on the Internet these days, and no one bothers with testing.
This message board design, for instance, sucks big time. It is unclear which message one is replying to. Had to delete this and re-post as I initially replied to my own comment above.
Why does every web site owner/administrator has this insatiable urge to keep changing things perpetually???

So I found that the save and view updates but you cant see the changes unless you clear browser cache in chrome.

Forced reload (cache bybass) usually works. Just hold the SHIFT key while pressing the reload button or the reload key (F5).

Its hit or miss for me with the preview thumbnails though I can publish it first try...

I experienced the same thing as well over the past couple days, while I struggled to understand why my previews did not generate.
I created a test thing and uploaded a test file. It saved, and I was able to edit it, but it would not publish, the screen just refreshing and staying in the edit mode. I deleted it since because it had the same preview problem as the real things.

Same for me.
I can upload a thing but "Publish" refreshes the edit page but the thing stays unpublished.

https://www.thingiverse.com/thing:4204735

Some STL files, one JPEG, using the latest chrome browser.

edit - Changed thing, deleted the old one for testing purposes. Problem still the same with the newly created one.

Bacteriophage Kit for Corona Beer Bottle

If I remember correctly it did this to me and I learnt that you have to "save and view" before you can publish. Hope this helps.
Alin

Tried multiple permutations of this. Still nothing.

Does it have an STL? It needs a 3D model or it won't allow you to publish. The "Download All Files" button will instead be a button that says something like "No files to download" if it doesn't have a 3D model.

That would be funny if he forgot to include the file itself lol.

2 stl, one jpeg.