Clicky

Loading

Newly uploaded designs are not showing in my design list

Please Login to Comment

I've uploaded and published 3 designs this week - other people see them and are liking/collecting them.
Only one of those designs appears in the design list for my account.
Two of them show up in searches, but one (Pen/Brush/Tool Rest Customizer) doesn't show up in searches or the recent uploads list.

What the heck is going on that has this site so incredibly broken?

Easy solution:

Leave thingiverse and move to printables.

They are getting better with each update and have an import feature for your thingiverse designs which works quite well.

I'm writing this after years of being patient and hoping for thingiverse to catch up. Instead, it's getting worse and worse. My last two uploads were impacted by this very bug. ATM I'm still publishing at thingiverse and then importing to printables. I guess I won't much longer.

I've given a bit more information about the issue here: https://www.thingiverse.com/groups/thingiverse/forums/general/topic:29812#comment-1891582

Basically: We think we found what is causing it and it's currently in the sprint to work on.

Thank you, Nallath, I appreciate that.

But this thread has been around for two years.

What does it tell us that the first time a thingiverse official shows up is after printables has been mentioned?

Nothing? Printables has been around for 3 years now. In the past i could not have helped you either, as i dont work for makerbot. Its only die to the merger between Ultimaker and Makerbot (that has been completed quite recently) thati am part of the group of developers working on thingiverse.

The reason that i respond now, is because i didnt want to necro old threads. But since you replied with a new comment, id figure that it would be good to share some extra info!

Glad to have new hands working on this site! I take you another common issue to you, if you want to check it out:

After saving an edit on an already created thing, at first, the changes on the description/images/files are not showed up in the page. You need to wait some minutes (yes, minutes, perhaps hours), or clear the browser's cache in order to see these changes in the thing's page. It's not like the edits are not saved, but, like the browser' cache isn't commanded to be updated after the thing is saved. This issue only occurs on each thing page so far, profile page updates instantly, for comparison.

Indeed, there is no reason to take this personally. My question was not why you in particular did not respond.

So Ultimaker and Makerbot merged and as a result there is an influx of personpower to thingiverse? That would be the first sign of hope after years of obvious neglect and teardown.

Yet, I remain sceptical. The bug discussed here is only one of a number things that got worse or stopped working at all over the years.

Hi Nallath,
There is just much frustration among the designers, who are not able to publish designs anymore – by whatever reason. Don’t take this personal. I’m sure, that I’m not the only one, who was happy to see, someone is trying to solve this issue, after many years of silence.
I wish you the best for solving the problem and I regularly check, whether my “hidden” designs become finally public/public again. As soon as this happens, I would return some more designs now published on printables. Not that I’m against printables, but I like Thingiverse more and would be happy, if I could publish designs here again.

I'm having a similar problem now. In Thingiverse it says I have 4 designs, but only 3 are accessible. Is there a work around?

Like I, and others, have pointed out, the only workaround is publishing it again. You can access to the missing thing via "Analytics", copy the content, and create the thing again. If the now invisible thing became visible eventually, you can delete it if you want.

Edit: Sorry, the "workaround", with ironic quotation marks.

Thanks. That worked, I don't know what I did differently, so I'll just be verbose about my steps. I created a remix, made sure I uploaded the STL first, uploaded the images, modified the text, hit save and view, saved the url (just in case), and then checked that it was in my designs.

There is no obvious cause for this "missing thing" issue, and it's been happening before this thread was created (July 2020). The best way to "avoid" this bug with the lesser cost, is to create a simple post, with one image for example; save it, check the thing is present in your profile (refreshing), if it's there continue editing, and finally, publish it.

This continues to be a HUGE PROBLEM. I have 113 designs on Thingiverse, but only 97 of them show up as they should, and I really didn't notice in many cases because these things are usually found from links at other sites, not by searching Thingiverse. Thingiverse has been entirely unresponsive to my support query as to what's going on and how to remedy the situation. Even more strange, today I was able to set two of my not-showing-up-and-unsearchable things as my favorites! My concern is not only that designs seem to sometimes not be completely present, but can we trust that ones that show up at some point will always show up?

You can't be sure at all! I last week tried to publish a new design. Not only, that the new design didn't get public another one, what was public for more than four weeks is now invisible too. I can see both in my personal account, but they are not public, no one else can see them.
No respond at all on support request... We're riding a dead horse! What a pity!

I uploaded 4 designs today and all 4 are shown in the iOS app, but only 3 of them are shown on my PC on both Chrome and Edge browsers. The browsers also show "4 designs" in the dashboard, but only show 3 designs and an ad when clicked.

This just happened to me. My latest published thing showed up on my analytics page, but not on my Designs page nor on other pages where it should have.

I saw that someone had liked it and I know that these "hidden" things show up on follower's dashboards, but the person who liked it isn't following anyone. So how did they see it? Well, it turns out that the old site design pages show it, so that's one possibility.

Knowing that doesn't help much since judging from the other comments, it's never going to show up and I'll have to create a new thing for it to show up where it's supposed to be visible. Aarrgh.

I guess it's now a good idea to save any new thing and make sure it shows up on your design page before publishing.

Some of the old site design page URLs are:
https://www.thingiverse.com/explore/popular/
https://www.thingiverse.com/customizable
https://www.thingiverse.com/newest

Thingiverse added the maintenance banner. May be after that update tonight, things that are now hidden from profile/searches became visible, as it happened two or three times after July 22 site update. Fingers crossed.

Or perhaps they break more of the site. This is the fun of being on thingiverse. You never know what's going to happen.

Yes, I expected too much from Thingiverse. I don't see any difference by now. They don't even fix the issue with the remix sources. May be things uploaded from now ahead will not fall in that limbo.

+1 !
Also can't find any items by ID or name when I want to add "this is a remix" when posting / editing a thing

Comment has been deleted

Same here, https://www.thingiverse.com/thing:4651548 not indexed or searchable but I can see it in my analytics.
Hoping for a fix

Persol 714 sunglasses adventure case

I've been waiting for this problem to be fixed for two months. I recommend you to just upload it again (and perhaps several times until it appears in your profile), if you want to have it visible. Not trying to be pessimistic, we are dealing with this issue for a while.

Awhile? Try YEARS!!!

Back then it was a few months after the last big GUI update. They never fixed many of the issues since then.

is not any solution?? .. naw i notice , not only my models upladed are not show in my designs , they also dont show in search resoults..

The only way un have it visible is uploading it again. We are all along in the same boat.

ok , i will try again , but i upload like 3 things in the las days and nothing apear to me. The only way i have to find them again one time i clote the tap , is add them to a "collection" ,, then i can find it there, but i guess nobody can see it , becouse it doesnt show in search engine.

Can some body have a look in my designs , and confirm me ,,if you can see (or not) my last thing uploaded called "Throtle part Flat"

i will realy apreciate it.

No, it's not visible, it is in that limbo that the only way out is devs making an update, like it was made some times before. I cannot help more than that, we are like this since ~July 22. You can check the "Issue and Feedback" section of this forum, this is happening periodically and randomly since then.

Edit: And, if your are hoping devs or admins see this forums, I've bad news for you...

thanks lots tato_713 , yes i have seen for long time oriblems reported from users, but it was working more or less for me.. at least untill few days ago i was able to uplead thnigs and see them in my designs. Olwais had some trubble with images and stuf like that,, but not that crazy like naw.

aahaha, shud be a big limbo some were .. full of "things" xDDD , and yehaa , i agree with your *edit , i know they will not fix nothing asap.

Then tomorrow will try to upload it again and again xDD if didnt apear, at least i will be feeting the kraken from the limbo
Thanks for your help , have a nice weekend

Same for you. I'm not happy with the way Thingiverse's staff is handle this site either. My way to "protest" is stop publishing things for a while. I'm planning to migrate most of my things to another platform. Cults or Pinshape seems to be the best options.

yes, defnly i will also i think.. becouse that is insane. im for lot of years in thingiverse,, but in the last years , what i see in the site is just abandone from makerbot part. is that dificult just have a simple platform working?.. i cant understand

We uploaded the design two times. The second was on few hours and it load downloaded a couple times. Now I cannot find them at all.

I edited the designs' text afterwards, wondering if that might something do with the issue.

New finding about the issue.

https://www.thingiverse.com/thing:4652272
My disappeared item cannot be found via Search nor it is visible on my listing. Though, it is visible on my Analytics section, somebody has been able to find&download the item.

Lifevest CO2 cartridge cylinder retainer
by jpnurro

It's also visible in the dashboard of your followers.

i have the same probelm ... is incredible , i can not find my last upload things :(

The site is working as intended. Well as it was intended to work six years ago. Lol
Due to limited resources the site can only make small fixes at any given time. This is due to a lack of funds and a out of date site environment.
Fixing things gets real tricky when you have nothing to work from.

This is a common bug since July 22 or so. I would give you more details, but there is a lot of talking about this issue in these forums. The best solution by far is re-uploading the entire thing. You can also wait until devs makes a site update (this is not happening), or you can leave this site and try Cults, Prusaprinters, Pinshape or whatever.

I just checked you uploads and I can see you designs, including the pen brush organizer. So idk what is up with that all I know is there are many problems that need fixing. I have even just worked my way around a similar problem, me designs wern't popping up but it said I had 3, so I tried filling out the misc comments box and what program I used to design it (which I hadn't done the previous 2 times.) Once I hit post I could see my designs very clearly then people started liking them. In other words, there is a lot of stuff this site needs to work best

I too uploaded one, and I can see it in the app - but I can't see it in my browser. The correct number of designs shows too.

Go figure?

I also had that problem with my poster frame, after I did what I said above ^, everything worked fine

I did originally fill in those extra boxes, but I didn't publish - just saved . . . . . . As I said, it was in the app, just not the browser.

So I tried again, followed your steps too - deleted the random crap from the fields from a weirdly linked thing (not mine, and this has been documented too), and then PUBLISHED the damned thing this time . . . .

Tah Dah, it's there, and if - sometime in the future - the original appears, I can just delete it.

Thanks for the input, it prompted me to give it another go.

No prob, its kinda stupid that you have to fill in nearly everything and then publish to get it to show up, but it works nearly everytime. I very much hope things get fixed at some point

The Thingiverse's app is just a webapp, and has not been updated for a year or more, so it has the old GUI implemented, so it hasn't most of the bugs from the new GUI since March. I downloaded it (again) a few weeks ago and it couldn't pass the login page.

I can pass the login page but I cant edit designs or look at peoples profiles and other crap

I would like to know too