Loading

Search is broken

Please Login to Comment

Can't find anything with the search now...

Ok seriously though, I tried again before pressing POST TOPIC and searching for "anything" now produces results, but other search terms of well used words are producing no results.

It's worse than that, Haku3D. Try navigating to the next page of results in the Site Issues and Feedback page. Same behavior. :/

Yep also at my site .... no search possible whether logged in or not. I have also issues with display of my designs or collections .... this happens since a few weeks in the evening ... I guess the Webserver or DB Server is overloaded and they don´t give a penny on it.
I have also troubles by viewing my designs... it shows me 32 but I can find only 29 or so ... I also wrote MakerBot a Email but they don´t care about me or my troubles.

I cannot search when I am logged in but i can search when i am not logged in.

Me too. I´ve found some issues during the searches:
During the navigation and after select the next page in the index (below) then suddenly appears "-1 0 1 2" in the index after refresh the page. Also very often after refresh the page, some pages are empty (No results found) and sometimes directly after press the next page in the index the website return to the page 1. Obviously, It's impossible to view all the models.
I use Safari and chrome and it doesn´t matter, i´ve got the same results. I hope that thingiverse fix that problems. It's really really annoying.

Same problem here and even after clearing cache it's still not working properly...

No, it's not, clear your cache and hard reload. When I search for 'anything' it displays flexible fish and other stuff.

Also broken for me.
For example try:
duplo => 0 Results
'duplo' => a lot of results, but clicking on second page doesn't work, shows same results as first
"duplo" => no results
'duplo' sort by newest => no results

Searching just now for duplo resulted in nothing, then I pressed f12 in chrome and right clicked the round reload button and then pressed the 'empty cache and hard reload' then the search results worked. Try that, if you're using firefox, try ctrl F5.

Thanks that works for me!
How to fix that for everyone who doesn't know this?

If they find this forum post as you did then they'll know. If you like, message every person with an account here and link them here, I guess.

The newest might not work with just clearing your cache, clearing the cache can't fix bad code.

Sadly it doesn't fix the issue with the "newest" ordering

the "fix" isn't working in all cases. I still get no result if I sort by Popular or Makes. I also got wrong pages index, and can't moving forward. Page index show -1, 0 , 1, 2

Clearing cache didnt fix the search, still getting "Page index show -1, 0 , 1, 2"

As I said, "clearing the cache can't fix bad code".

Agreed. Bad code where one have to clear the cache multiple times just go to the next page on a search. And often clearing the cache doesn't help at all.