Loading

Unable to Upload things

Please Login to Comment

For the past month, I have been trying to publish a new thing and it just isn't going public. I have tried everything and with no luck. My things remain stuck on loading as visible in the image.

Try uploading a photograph in addition to the STL files. I have had problems if I include only STL files. Also problems if I don't include any STL files (used to be, STLs weren't required, you could upload 3MF or OpenSCAD or whatever).

Your best bet is to upload your design to a better site such as printables.com. See this as an example https://www.thingiverse.com/thing:5154983

This has been a bug on the site for some time and there is no sign of it getting worked on or fixing itself

Garmin Approach R10 Golf Launch Monitor Stand - Shot Alignment and Leveling Aid
by mcfada

This is a common bug with Thingiverse and it does need to be solved. It sporadically happens (over the last year, at least) where you upload a thing, save it, and it does not show up in your Designs and you cannot find it when searching. However, others seem to find it and if you look through your notices (!) you will see people liking it, saving it, etc. Then, all of a sudden, it will appear in your designs. I had a couple that took a few days and one that took months - about 4 months to show up, IIRC.

Is this happening with all files you try to upload or only this specific one? Maybe the file is too big or it isn't the right format. Can you upload it somewhere else? That might help to figure out the reason.

I have tried over 5 files and they all have the same problem. Their format is STL.

Strange... Can you attach one of these files here? If that works out I can try to reproduce the issue.

I tried to upload the Samsung file which worked just fine. Maybe this is just a browser cache issue. After uploading, try opening the thing's page in another browser, private window or device. Or, you could just go ahead, publish the thing anyways (even if the preview isn't working.) If, after that, you post the link here, I'll check if I have the same 'not loading'-issue.