Loading

TronXY X5S Marlin 1.1.6

Marlin Marlin 1.1.6 marlin_firmware TRONXY tronxy_X5S

Please Login to Comment

Hello, everybody.

I just finished the Marlin 1.1.6 adapted to the TronXY X5S, and I share it with you.

I hope you find it useful.

It is configured in Spanish but you can easily change it to English in the Configuration.h file.

https://drive.google.com/open?id=1MXdR7Ja67GzHObWctFXaHVubpy08xo9a

Bye!

Comments deleted.

HI

Thanks for the link. Now I'm able to save settings to the eeprom. I also edited the configuration_adv.h file to stop my stepper motors from timing out. If anyone is interested just search for the string

define DEFAULT_STEPPER_DEACTIVE_TIME

and change the default value of 120 to 0 and they'll stay locked up all the time when the power is on.

FYI I didn't have to load the bootloader

Followed your instruction and successfully updated to Marlin 1.1.6
Just want to say THANKS!

Below is the English instructions for those who need it.

  1. Download and install Arduino IDE 1.8.x

  2. Install Sanguino
    In preferences add this URL for additional board manager:
    https://raw.githubusercontent.com/Lauszus/Sanguino/master/package_lauszus_sanguino_index.json
    Go to the Board Manager and install the Sanguino.
    Select Sanguino and select the atmega1284 16mhz.
    Select the port where the printer appears

  3. Install u8glib for OLED Display
    Go to the libraries and install the u8glib

  4. Change upload speed
    Go to the Arduino Preferences and at the bottom find link to more preference in the directory for "preferences.txt"
    Click the link to folder, browse to \packages\Sanguino\hardware\avr\1.0.2\boards.txt
    Change the line to following:
    sanguino.menu.cpu.atmega1284p.upload.speed=57600
    Restart the Arduino IDE (Important)

*4. Change language setting
Change the language setting in configuration file to "En" (English)

  1. Compile and upload the firmware

Hallo, good afternoon!

Thanks for the guidelines you all posted.

To be honest, I'm just about to cut my vains!!
This bloody X5S is still not working and after really many many hours of reading and trying it is not funny anymore...

I followed carefully any of the described steps and actually my X5S dos not respond at all ...
neither with cura, nor with repetier and Pronterface tells, after Connectig:
"Attempted to write invalid text to console, which could be due to an invalid baude rate ..."

Any suggestions before I take the sledgehammer and kill the F-board .... I'm really out of my brain!!!

Just posted a brand new version of the instructions that are as simple as you can get... no tools needed http://www.customize-3d.com/tech/flashing-tronxy-x5s-factory-control-board-usb-cable-only.html

i have tried this and i get this message oops! make sure 'arduino mega' selected any ideas?

What version of windows? Did you fallow the article step by step including making sure all old versions of arduino is uninstalled?

win 7 and yes everything was uninstalled it gave me the same message before i went with your easy setup

Did you check all the settings I show in the pics... I'm not really that good at arduino I just did all the backend edit to the portable version to make it easier for others...

Yes I even tried it using my wifes laptop and get the same result is it possible that they changed the chip. I have the v2 board in mine

Board version doesn't matter I have flashed about 15 of these exact board now. I never got the same error your talking about... might have to go to the other way to flash firmware after adding bootloader with a usbasp or uno

thanks i will give that a try

I used to use the usbasp and it worked great just have to burn bootloader with then.other instructions on my site for using the uno as well

Dear DracenKnights (S.W.),

allow me a few words to say thank you ... not only for the dumb-proof tutorial, but as well for your time invested.

Great!!! It works, and it really does fine!!

I'm now wondering why it didn't work before ... Maybe because I was using Marlin 1.1.6 ? (Any known issues with this?)
A wrong edited 'boards.txt' ?
Maybe a wrong path ?

Basically this is what I was doing ... (!!!???) ...

A very good piece of advice was to remove all older Arduinos and keep things clear!!

Thanks again mate for your time. Believe me, I really do appreciate!

Visi Tor (O.H.)

Thank you... that's a true stand alone version of arduino ide ...

I just try to pass information on as I can, not all the site is my writing and there is a forum on there as well and we have a Facebook page and group as well.

Sorry to ask a noob question but can you give us steps on flashing. I am OK with Arduino just not too good with this x5s board yet. For example which is the jumper to get it in programming mode?

I didn't have to touch anything on the board, no jumper.

In your Arduino IDE Tools menu, what type of Programmer are you using? I tried several options this morning without success.
Regards

It doesn't matter. It is not used to upload the firmware.

Thanks for your answer, I found that the Arduino IDE is trying to update de firmware with the following command:

"C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avrdude" -C"C:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf" -v -patmega1284p -carduino -PCOM3 -b115200 -D -Uflash:w:C:\Users\Win10\AppData\Local\Temp\arduino_build_352982/Marlin.ino.hex:i

It doesn't work. It shows some communications problems.
I tried different options and changing the baud rate to 57600 solved the problem.
So the final command, that I ran from the command line in Windows to update the firmware is the following:

"C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avrdude" -C"C:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf" -v -patmega1284p -carduino -Pcom3 -b57600 -Uflash:w:C:\Users\Win10\AppData\Local\Temp\arduino_build_352982/Marlin.ino.hex:i

Perfect. Thx.

Oh, really? JUST connect up to the Arduino IDE select Sanguino board and hit compile? What about what I have read on other posts about needing to run it through an Arduino due to the lack of a boot loader?

My Tronxy X5S board has the bootloader installed.

What version of arduino IDE did you use? I have not been able to compile the version I have. There seem to be many files/drivers? that I don't have holding me back. I may contact you for more information when I get back to it. Long story, but the short version, my controller board smoked within the first 5 mins of building my X5S. I haven't received the replacement yet.
Thanks for posting.

I use the Arduino IDE 1.8.5.

You have to install in the Arduino IDE the Sanguino libraries for the Tronxy board, and the u8glib libraries for the screen.

Bye!

Can you make a tutorial please? I didn't get it to work like you said. In Arduino IDE I get the error "The current selected board needs the core 'arduino:arduino' that is not installed."

I guess this is for the orginal board and not for a arduino?

Hello. It's for the original board.