Loading

Marlin Firmware

Please Login to Comment

Hello, anyone who have managed to create a working marlin firmware for z360 printers?
i keep geting "out of printing area" message every time i try to print.
If i skip through bed leveling prosses, it works. if i level it it won't.

Hi Guys,

my jennyprinter 3 is running well with the original Ultimaker 2 Merlin version. My problem with the diamensions is solved and it based on a EPROM full of rubish. That means old values for the micro stepping weren't overwritten and I wasn't able to use new values. I found out that I have to clear the EPROM. I used the EPROM clear program which is foundable in the examples of the Arduino Editor. Just uploaded to my mainboard. After this the EPROM was deleted. I installed Merlin again with my micro stepping adjustmens and all works like a sharm.

Regards
Oliver

Where can I find better firmware for my jennyprinter z360ts that's better than stock? All of a sudden I have printing issues. Among the problems is that it's in Chinese language still and the video they sent me to change the language isn't what my jenny shows. I am also using simplify 3D. It was printing fine and I don't know what happened but now thr nozzle will print then go to the the end stops then go back to print a layer then do it again. Just wonder if i can or how to flash it with different firmware to get better results.

Hi everybody,
I got my JennyPrinter 3 DIY Kit (not the extend version/Z360 ) some days ago and I assembled it in round about 10hrs. The Problem I have is, the original firmware works not really good. I got problems with the micro stepping. X and Y is half as it should and it seems that the print area is limited. On the mainboard aren’t any jumper which I can use for micro steppings adjustments. I downloaded the Ultimaker 2 marlin version and uploaded to the mainboard. Before I did this, I doubled in the configuration.h the x and y endstop values. The values for the micro stepping didn’t take effect to X and y, only to the z axis. The original settings are the following: #define DEFAULT_AXIS_STEPS_PER_UNIT {80.0,80.0,200,282}
I doubled or halved the first both values but no effect on both axis.
Is there is somebody who could deal with this problem? Any ideas?

Should I use M92 code for X and Y axis in the start script?

Many thanks and regards
Oliver

Anyone know how to change the language from Chinese to ENGLISH!!!??

at startup for the first time it should be changeable. If not, just flash the firmware from SD-Card to your Eprom and the language menue will be come up.

I just got this jennyprinter z360ts so I'm not very familiar with it. When I 1st turned it on, it was already in Chinese so I don't know what is what. Also I'm not sure how to flash the firmware with the sd card, I also don't want to mess it up, ive only printed 3 calibration cubes with it so far.

But if you read the instruction on SD Card, than you have to update the firmware anyway. Let me check tonight the menue steps and I will guid you. The firmware has only 2 laguages, you couldn't change from one understandable to anotherone.

hello everybody.
Someone the have the original firmware for a jennyyprinter z360 dual extrudeur.
Because my printer won't work , my calbration aréa is too small. I don't understant why
If someone can send me the original in private ?
I will be the most happy of the world.

your microstepping for x and y has to be adusted. This can be done directly in the firmware (before upload) or you can send G-Code to adjust it. First of all you can read out which setting is setup. Type in M501 and send it to your printer. Copy and past the next view lines which are comming from your printer as a response in here and I will have a look. It could be also the problem that the software endstops are not right. You can use a normal Ultimaker 2 merlin firmware which can adjusted. Ther might be a compiled firmware on your SD-Card which came with the printer. But this is already compiled and can't be adjusted.

HI Guys,
I have a jennyprinter with the touch screen i think they call it a Z360TS, any way i am having some issues with it especially with the lowering of the z axis and if the z axis is at the top, when you go to print it comes about half way down and then just squirts plastic everywhere, if I switch off the printer and manual push the z axis to the bottom then restart a print it comes up to the correct height and starts too print but I need to adjust some stuff as i think their firmware is not good, any help would be appreciated, since I am new to this detailed step by step instructions would be great, I would love to upgrade this to the Ultimaker firmware but not sure how?

I downloaded the latest Cura, set the profile to Ultimaker 2 Extended and told Cura to update my firmware to the latest from the net...which it did. I then tried to do a print and found that the extruder now runs backwards...in a stroke of genius I decided to just flip the extruder (and the intake/exhaust ports) and BOOM, my z360 is now an Ultimaker 2 Extended. Simplify 3D and Cura both use the default Ultimaker 2 Extended profiles with the only change is setting the Z height to 360 rather than 305.5 or whatever it thinks it is. Even powers up with the Ultimaker logo. Mind you, I had a backup of my original firmware on the SD. Do this at your own risk.

Hi, I have test your solution. Because m'y Jenny don't work . But I have not the original firmware.
Can you sand me yours . Dis toi have a look to download it.

Thanks

Hi what do you men flip the extruder? sorry for being a noob, but the jennyprinter i got has been an absolute nightmare, i am onto my third mainboard as when i followed the sellers instructions when selecting the model with the touchscreen the machine froze and refused to boot, would love some help if possible.

Whats the benefit of running ultimaker firmware, the sanjiu firmware seems good havnt had any issues yet other then not being able to use Cura 2.4 with dual extruder, question how do you get old firmware back on if i change.

Ultimaker firmware is not much i think. But if you compile your own marlin firmware, one have an option to update and edit it as you wish. Don't think sanjiu or jennyprinter is so active on updates with new features in marlin firmware.

The original firmware is on your SD card that came with the printer as well as software to install it.

Thanks heaps might try it curious can you change filament size though running ultimaker firmware?

Gave it a shot. got backup of working firmware saved.
1: Cura 2.4.0
2: Ultimaker 2 Extended Auto firmware update
3: Factory Reset
4: Simplify3d (change steps pr/mm) don't know why it puts 80 on x and y when it suppose to be 160 according to "belt and pulley calculator"
5: Level the bed
6: Feed and select material
7: Select something to print (from a freshly added UM2 extended profile with hight edited)
8: Heated Up
Final result: ERROR: Tried printing out of printing area "Return To Main"

Mate i did what you did and for the same on final result, but i used simplify 3D what did you do to fix

i use simplify3d myself for slicing. i had to use another Startup Script to get it working.
TheExplorographer posted his below, and i modified it to my needs a bit. working like a charm now :)

Hi I know this thread is a couple weeks old but I just finished building a z360 and was trying to figure out how to get simplify3d to work with it. I noticed your start and end codes but wanted to check and see what firmware you were running with it. Are you still on the sanjiu firmware or did you update to the ultimaker firmware before using these scripts. I noticed in the simplify3d default profile for the ultimaker 2 extended that the first line is an M code to increase the extruder current? Is this not necessary then? Sorry to throw so much out there at once. Thank you for posting what you have so far though. It has given me some things to try I just want to be certain before I do anything drastic. Thank you!

Hi. no problem.
i'm currently running a single nozzle firmware from jennyprinter on mine.
as far as i know, i didn't have any current increase code in mine on S3D (i do use UM2 extended profile with start/end script i posted here)
i plan on going to ultimaker firmware from cura update when i'm done building another printer so i can't have downtime on mine z360 just yet.
I had to change start/end scripts from original UM2 profile to work with my z360 on UM firmware because of an error on dimensions of the heated bed.
if i'm not wrong, sanjiu printers come with built in stepper driver and "firmware" controlled current adjustment, jennyprinter comes with polulu drives and manual adjustment.
if you got S3D profile on your sd-card that came with the printer as mine did, you can se if there is an increase code.

Short version: remove the increase code line and give it a try.
worst thing that can happend would be underextruding i guesse and some noises when skipping on filament.
if you got a part number on your extruder motor you can google it and se ho much current it can handle and compare it to what M-code tell it to increase to.

Sorry if there's any typo's, english is not my native language.

Thank you very much for your help! After trying a few things I discovered that the start and end scripts from the explorographer work great. However I have the new version of the sanjiu extruder which has two drive gears and seems to suck a bit more power. That seems to be where that M code at the beginning comes in. I suppose the ultimaker 2 originally came with an extruder that uses the same amount of power, or close, because when I put that m code into the code from the explorographer everything turned out perfect. On the aliexpress page for this extruder it recommends a pulse rate of 300 which I'm assuming is 300 steps/sec and simplify3d does its calculations in minutes. It would be 1800/min but I have no issues with mine at 1400 so far so that would be my suggestion.. Hope this can help someone else down the line. :) Just for reference the code is:

M907 E1400

Good it worked out for you :D
If it's their geared extruder they are selling with 2 white plastic gears, i got 2 og theme :D awsome stuff. Best one's i have ever had
You can change in settings in s3d from minutes to seconds :D

Hi I actually had another question for you if you have a minute. I do indeed have that same extruder and I know we have different setups but I've noticed that even after increasing the extruder current I get some clicking and skipping during the printing of the raft and infill. It ends up resulting in weak infills and raft layers. The aliexpress page says something like "we advice the feeding E-motor with 300-pulse". So do you think it would be alright to change the m907 code to E1800? Which would be the equivalent in mm/min. I know this is probably not a question you have a direct answer to I'm just curious for your advice. Thank you again!!

i did have the same problem with both old and new extruder/feeder.
i had stringy infill and realy weak, and alot of under extrusion and skipping layers.
did do a rebuild of printhead and nozzle to se if it was cloged, sometimes it was ozzing out between tube and nozzle. then calibrated steps pr/mm, extrusion width and multiplier. did an almost sergiclaly clean and straight cut of bowden tube that goes into printhead and to nozzle.
tightend extruder to push more on the plastic as it feeds it up the tube. and everything just went away.

didn't bother with the 300 pulse motor and just went for it and tested. have no idea what it means.

Thank you for the advice! How exactly did you go about tightening the extruder if you don't mind me asking? Also I was curious how you calibrated the steps per/mm. We have different boards I believe so I may not even be able to adjust that but I'm just curious how you went about it with your machine. Thank you again!

there is a hole on the opposite site of the "button" you push inn to feed filament.
calibrating steps have nothing to do with the board.
you can try and connect it to you computer/mac.
connect to the printer with simplify3d, remove plastic from machine, disconnect your bowden tube from feeder, not the print head.
push plastic trough extruder so it sticks out i tiny bit on the top so you can mark your starting point,
preheat printhead to 170-180 and make simplify extrude 100mm of plastic. when it's done you mark a new spot. I use the pres-fit fitting as reference to mark start and end points. then you mesure how much it extruded.
then you go to "Communication" tab in Machine controll panel and write M501 and it will spit out som numbers.
Turn off "verbose" so it doesn't scroll past everything and look for a line:
Steps Per Unit
M92 X160.0 Y160.0 Z200.0 E350.0 (these numbers are just reference, same numbers will be used later on, just as reference)

E350.0 <- extruder steps
Now you know how many steps it takes to extrude 1mm filament.

mesure your "extruded" piece of plastic if it's very close to 100. you don't need to change anything
if its more or less you need to calibrate.
here comes the math:
let's say you extruded 78mm and not 100 like you wanted.
You take the number from before(E350.0) and multiply it by 100 <-- the lenght you wanted to extrude
350*100=35000
then devide 35,000 by the lenght you got extruded, in this case 78
35000/78=448,717948717948718
447,72 <-- you new steps pr/mm
now you turn "verbose" back on so it starts to scroll in communication tab.
write:
M92 E447.72 <-- sendt it.
M500 <-- To save changes
send M501 to double check if it is in fact saved and says:
Steps Per Unit
M92 X160.0 Y160.0 Z200.0 E447.72

i belive printer will reboot and reconnect to simplify3d.
when it reboots your hotend will have to be preheated again.
repeat until you get as close to 100 as possible.

i have 1256 steps pr/mm on mine to make it extrude within 100,00 and 100,50mm

First of all, your explanation helped me a lot, thanks for that. I’m using simplify3D and I have problems with the retraction
distance settings. If I have a part with vertical holes thru the whole object, the infill and outer lines in that height of the
holes looks not really nice and the part can be break very easily. The rest (before and after) looks good. I think that
these has something to do with the retraction settings.

Could you please let me know about your settings? What settings do you have with the Jenny Clone? Many thanks

My settings on retraction are:
Retraction Distance: 6.70
Vertical Lift 0.50
Speed: 25
Coasting 1.30
The rest are 0 or disabled.
i'm printing pla at 185/55 with 40mm/s

And another thing, i use 35x35 radial fan cooler as layer cooler.

Fantastic. Thank you so much. The in depth description is seriously appreciated. Still new to the world of Bowden stuff and this is a bit different than working with this stuff on my direct drive system on my other printer. I will go and calibrate now. That was much easier than I had expected. I only did this once before with my old printer and I used my old slicer that came with that printer so this is all a bit new. Thank you!!

No problem, glad to help :)
saw you mentioned earlier you used simplify3d so it made it so much easier for me to explain since i use S3D myself :D
feel free to ask if there's anything else.

Sin_Vaffel

Yes i did try his script, would you might sharing script you have used. Have you tried dual print at all. Thanks again for you help.

G28 ; home all axes
G1 Y10 Z10 F3000 ; bring extruder to front
G1 E25 F250 ; purge nozzle quickly
G1 X190 Z0 F9000 ; pull away filament
G1 X210 F9000 ; wipe
G1 Y10 F9000 ; wipe

Here you go. maybe you will have to edit it of some sort. i have to push filament up the tube before every print since it retracts it back at the end in the firmware.

Cheers Mate

Works a treat. ill give dual ago when this one all sweet let you know.

Cheers

I'll post it when i get home from work.
i did try dual print, but never got it working properly with offset and everything, so i ended up removing second nozzle and having it as spare parts. mostly in favor for 2x radial blower fan cooling for filament. my stock cooler was horrible and every other "dual nozzle" fan brackets didn't do well.

Comment has been deleted

maybe thats where the problem is, i got Jennyprinter version.
does yours use pololu drives?

Not sure what you are changing as far as steps go in Simplify3d. I made no such changes. The only changes I made were to the start and ending scripts..they should be:

Start Script:
G28 ; home all axes
G1 X0 Y20 Z0.1 F3000 ; get ready to prime
G92 E0 ; reset extrusion distance
G1 X200 E20 F600 ; prime nozzle
G1 X0 Y25 Z0.1 F3000 ; get ready to prime again
G92 E0 ; reset extrusion distance
G1 X200 E20 F600 ; prime nozzle
M201 X1000 Y1000 ; slows acceleration

Ending Script:
G28 X0 ; home the X-axis
M104 S0 ; turn off heaters
M140 S0 ; turn off bed
M84 ; disable motors

You'll notice I have it print two lines in the beginning. This was because I had my flow too high... I have it adjusted properly now but I have not removed the extra prime run to clear the head. This works. I have not made any other changes to Simplify 3D's Ultimaker 2 Extended Profile other than flow tweaks per material.

i need to change steps pr/mm from 80 to 160 on x and y axis or it will only travel 1/2 the distance it's need.
with your start script, works like a charm now :D thank you.