Loading
nebbian

"Z Bend" Z Sensor

by nebbian Apr 25, 2016
Download All Files

Thing Apps Enabled

Please Login to Comment

would this work on Cartesian as well as delta printers?

Yes, but there’s no point in doing so. The problem with deltas is effector tilt, which doesn’t happen on cartesians - and the whole point of this sensor is to be immune to effector tilt.

Excellent!
One hundred "Like" !!!

Comments deleted.

Hi great job . I am bulding a rostock printer amd decide to use Your probe to autolvl .However I stock with the firmware config , in new malin 1.1.0-RC7 i am unable to find some options from description , can may You post the line nombers where to find the options from descriptio ( I can not find there define Z_RAISE_BEFORE_PROBING 50 // How much the Z axis will be raised before traveling to the first probing point.and many others , I am blin or just dump ;p

It seems that you're neither blind nor dumb, it's just that Marlin RC7 removed those options :-) They are now:
Z_PROBE_DEPLOY_HEIGHT
Z_PROBE_TRAVEL_HEIGHT
The devs have also changed the bad curved movements between probe points, so these defaults should work fine. Let me know how you get on.

I det them and get to point where i have to set : #define Z_ENDSTOP_SERVO_NR 0

define SERVO_ENDSTOP_ANGLES {{0,0}, {0,0}, {5,80}} // X,Y,Z Axis Extend and Retract angles , it says in marlin For a servo-based Z probe, you must set up servo support below, including

// NUM_SERVOS, Z_ENDSTOP_SERVO_NR and Z_SERVO_ANGLES. , but below i cannot find nothing when i check that above it automaticly recognize as i try to use 2 diferent z probing systems at the same time . I run it also on repetier , there i could check that the servo and the optical endstops was working .

You might have to do a bit of investigation on your own here. Without more information I can't see what the issue is, apart from maybe changing the num servos to 1, setting the endstop angles to 5,80 on all of them, not just the third one, and setting Z_ENDSTOP_SERVO_NR to 1.

I'm using repetier now, and it's working just fine for me.

Great Job. Thank you.