Loading
meie1kyl

Anet A8 & Hephestos BLTouch Mount- Simple installation!

by meie1kyl Oct 25, 2016
Download All Files

Thing Apps Enabled

Please Login to Comment

I just printed this today and added a knockoff version of the BLTouch to my A8. This is one of the few things I've printed off of Thingiverse that worked perfectly on the first try. Thanks for the design and for sharing the files... I was surprised by the amount of effort that's required to add Auto leveling to a printer but with $15 in the sensor and a few cents in the material to print the connector it was well worth the time. My first print with auto leveling is running right now and the first layer was absolutely perfect.

Thanks for the kind words :-) I was surprised as well, this was the first time I added auto leveling. Once I had the config figured out I was sad to realize I didn't have a way to mount it. I figured since it was a pain to design and tweak, I'd share the file and really didn't expect it to become this popular

Thanks for the upload, it's printing as I'm writing this. Just a quick question though. I have a BQ Prusa i3 Hephestos and I see that you have two folders in example_configurations. One named Witbox and one named Hephestos. Which one should I use for my printer? It is a prusa i3 hephestos with a Witbox extruder (though the hot-end was replaced with this one https://www.bqstore.nl/en/bq-prusa-i3/70-hotend-heatcore) - if this plays any role at all.
Looking forward to your reply.

Thanks for the download and print! I believe that Marlin file was downloaded from BQ so the example configs are from them. The configs I modified are Configuration.h and Configuration_adv.h which are located in the main Marlin folder, not the example folder. Be sure to review those config files for any possible differences between the printer I was using and your printer.

I was just checking through the configuration.h file in the marlin folder that you uploaded and it doesn't have auto bed levelling enabled. Is that correct?
Do I enable it myself or just upload the file and it should work?

The configuration.h I uploaded is more of a guideline. I'd assume you want the ABL enabled. Check the PDF included in the downloads for better information.

Can you upload and/or link a CAD file for the A8 version? Alternatively, is the i3 version the same but with the little piece hanging down? I'd like to make a few changes to the A8 version, after printing what you have I found that my sensor is 3.53mm too high. It also puts the sensor a little close to the bracket pinching the wiring a bit.

Hello dear, I'm using this holder on the Anet A8 with this settings
"define X_PROBE_OFFSET_FROM_EXTRUDER -22 // X offset: -left +right [of the nozzle]
define Y_PROBE_OFFSET_FROM_EXTRUDER -45 // Y offset: -front +behind [the nozzle]
define Z_PROBE_OFFSET_FROM_EXTRUDER -2 // Z offset: -below +above [the nozzle]"

but the sensor seems not working because it doesn't stop. It goes and push the bed until I reset the printer. How can I fix it?

Make sure you have both sets of wires connected to your RAMPS board. Sounds like your endstop connection may not be correct.

I'm following this scheme. I'm not using RAMPS board.
I successfully used this sensor with this configuration but I had to change the holder so I had to reset everything, reupload the firmware etc etc.
I'm gonna re-wire everything and I'll tell you more.

EDIT:
It seems that the sensor cannot touch the bed because is above the nozzle than the nozzle goes down without stop.

EDIT2:
I added a nut between the holder and the sensor and now it can reach the bed.

Thanks for the follow up on your problem! Yes, sometimes the bltouch may need to be placed lower than the standard mounted height. I didn't figure it would be a firmware issue, it seemed the control board was not receiving an endstop signal which was true in your case just a different cause :-) Glad you got it figured out!

What is your X,Y,Z offset for this bracket?

Someone can check this value for me?

define X_PROBE_OFFSET_FROM_EXTRUDER -22 // X offset: -left +right [of the nozzle]

define Y_PROBE_OFFSET_FROM_EXTRUDER -45 // Y offset: -front +behind [the nozzle]

define Z_PROBE_OFFSET_FROM_EXTRUDER -2 // Z offset: -below +above [the nozzle]

It seems to work here, thanks!

Hi, can you please upload the wiring on the board?

Page 2 of the uploaded PDF (BLTouch_Setup_Instructions.pdf) covers wiring

Where did you get that fan duct stl?

Holder for inductive sensor LJ12A3-4-Z/BY
by maffie

What do you mean with "I measured it at 6.08 mm from extruder nozzle to the bottom of the housing. This is supposed to be 8mm, so I adjusted the height" ?

My BL Touch gets into Alarm, if ithe the Nozzle at 0,1mm above bed (cold nozzle) and power up the printer.
I thought it must me 8mm +/- 0,2 from the housing and the tip of the nozzle.
Do i just need to move Z just u little bit up ?
I Dont want to start anything before i know this :-) Dont want to crash my Filaprint or the sensor.

The z offset can be adjusted with command M851. See detailed instructions on pg 5 of the BLTouch_Setup_Instructions PDF that's in this item's list of files.

do you have your firmware for the bl touch

Comments deleted.

I'm currently adding a heated bed and trying to get that set up and working correctly (along with printing ABS for the first time). I'll be sure to update this with the firmware info when I get the probe working properly.

Hello, are you still using this same firmware? The one uploaded on your update on 1/4/2017 thanks

I'm 90% sure it's the same firmware. I'm working with two different printers at tho moment so it's a little tough to keep it all straight.